zoukankan      html  css  js  c++  java
  • POJ2739(尺取法)

    Sum of Consecutive Prime Numbers
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 23931   Accepted: 13044

    Description

    Some positive integers can be represented by a sum of one or more consecutive prime numbers. How many such representations does a given positive integer have? For example, the integer 53 has two representations 5 + 7 + 11 + 13 + 17 and 53. The integer 41 has three representations 2+3+5+7+11+13, 11+13+17, and 41. The integer 3 has only one representation, which is 3. The integer 20 has no such representations. Note that summands must be consecutive prime 
    numbers, so neither 7 + 13 nor 3 + 5 + 5 + 7 is a valid representation for the integer 20. 
    Your mission is to write a program that reports the number of representations for the given positive integer.

    Input

    The input is a sequence of positive integers each in a separate line. The integers are between 2 and 10 000, inclusive. The end of the input is indicated by a zero.

    Output

    The output should be composed of lines each corresponding to an input line except the last zero. An output line includes the number of representations for the input integer as the sum of one or more consecutive prime numbers. No other characters should be inserted in the output.

    Sample Input

    2
    3
    17
    41
    20
    666
    12
    53
    0

    Sample Output

    1
    1
    2
    3
    0
    0
    1
    2
    思路:尺取法操作连续子序列。
    import java.util.Arrays;
    import java.util.Scanner;
    
    public class Main {
        Scanner in = new Scanner(System.in);
        final int MAXN = 10005;
        int[] prime = new int[MAXN];
        boolean[] isPrime = new boolean[MAXN];
        int[] sum = new int[MAXN];
        int total;
        void table() {
            Arrays.fill(isPrime, true);
            isPrime[0] = false;
            isPrime[1] = false;
            for(int i = 2; i < MAXN; i++) {
                if(isPrime[i]) {
                    prime[total++] = i;
                    for(int j = i + i; j < MAXN; j += i) {
                        isPrime[j] = false;
                    }
                }
            }
            sum[0] = 0;
            for(int i = 1; i < total; i++) {
                sum[i] = sum[i-1] + prime[i-1];
            }
        }
        Main() {
            int n;
            table();
            while((n = in.nextInt()) != 0) {
                int res = 0, sum = 0;
                int front = 0, rear = 0;
                while(true) {
                    while(rear < total && prime[rear] <= n && sum < n) {
                        sum += prime[rear++];
                    }
                    if(sum == n) {
                        res++;
                    }
                    sum -= prime[front++];
                    if(front >= total || front > rear) {
                        break;
                    }
                }
                System.out.println(res);
            }
        }
        public static void main(String[] args) {
            
            new Main();
        }
    }
  • 相关阅读:
    axios、ajax、fetch三者的区别
    React与Vue的相同与不同点
    react-redux
    redux【react】
    react高阶组件
    基于WebGL无插件虚拟场景漫游关键技术(完整版)ThingJS
    基于WebGL的三维交通监控可视化技术应用(实践版) ThingJS
    地下管线监控系统中互联网WebGL三维可视化构建技术 ThingJS
    基于WebGL实现智慧校园的全景漫游技术研究 三维可视化
    基于WebGL的3D可视化告警系统关键技术解析 ThingJS
  • 原文地址:https://www.cnblogs.com/program-ccc/p/6111923.html
Copyright © 2011-2022 走看看