zoukankan      html  css  js  c++  java
  • PATA 1011 World Cup Betting (20)

    1011. World Cup Betting (20)

    时间限制
    400 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

    Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.

    For example, 3 games' odds are given as the following:

     W    T    L
    1.1  2.5  1.7
    1.2  3.0  1.6
    4.1  1.2  1.1
    

    To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1*3.0*2.5*65%-1)*2 = 37.98 yuans (accurate up to 2 decimal places).

    Input

    Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

    Output

    For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

    Sample Input
    1.1 2.5 1.7
    1.2 3.0 1.6
    4.1 1.2 1.1
    
    Sample Output
    T T W 37.98


    #include <cstdio>
    #include <algorithm>
    using namespace std;
    double win[4],tie[4],lose[4];
    double maxodd[4];
    double maxofthree(double x,double y,double z)
    {
    	if(x>=z&&x>=y)
    		return x;
    	else if(y>=x&&y>=z)
    		return y;
    	else if(z>=x&&z>=y)
    		return z;
    }
    int main()
    {
    	for(int i = 1;i <= 3; i++)
    	{
    		scanf("%lf%lf%lf",&win[i],&tie[i],&lose[i]);
    		maxodd[i] = maxofthree(win[i],tie[i],lose[i]);
    		
    	}
    	for(int i = 1;i <= 3; i++){
    		if(win[i] >= tie[i] && win[i] >= lose[i])	{
    			printf("W ");
    		}
    		else if(tie[i] >= win[i]&&tie[i] >= lose[i])
    		{
    			printf("T ");
    		}
    		else if(lose[i] >= win[i]&&lose[i] >= tie[i])
    		{
    			printf("L ");
    		}
    	}
    	double ans = (maxodd[1]*maxodd[2]*maxodd[3]*0.65-1)*2;
    	printf("%.2lf",ans);
    	return 0;
    }
    

      

  • 相关阅读:
    c#中文字符串与byte数组互相转化
    c#的中英文混合字符串截取 public static string SubString(string inputString, int byteLength)
    c#的中英文混合字符串截取指定长度,startidx从0开始
    //字符是否为汉字
    //获得字节长度
    C# 截取中英文混合字符串分行显示宽度相同
    C#截取中英文混合字符串分行显示
    C#截取指定长度中英文字符串方法 (修改)
    截取字符串的长度(中英文)
    canvas贪吃蛇游戏
  • 原文地址:https://www.cnblogs.com/qiangz/p/8447236.html
Copyright © 2011-2022 走看看