zoukankan      html  css  js  c++  java
  • PATA 1011 World Cup Betting (20)

    1011. World Cup Betting (20)

    时间限制
    400 ms
    内存限制
    65536 kB
    代码长度限制
    16000 B
    判题程序
    Standard
    作者
    CHEN, Yue

    With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

    Chinese Football Lottery provided a "Triple Winning" game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results -- namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner's odd would be the product of the three odds times 65%.

    For example, 3 games' odds are given as the following:

     W    T    L
    1.1  2.5  1.7
    1.2  3.0  1.6
    4.1  1.2  1.1
    

    To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1*3.0*2.5*65%-1)*2 = 37.98 yuans (accurate up to 2 decimal places).

    Input

    Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

    Output

    For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space.

    Sample Input
    1.1 2.5 1.7
    1.2 3.0 1.6
    4.1 1.2 1.1
    
    Sample Output
    T T W 37.98


    #include <cstdio>
    #include <algorithm>
    using namespace std;
    double win[4],tie[4],lose[4];
    double maxodd[4];
    double maxofthree(double x,double y,double z)
    {
    	if(x>=z&&x>=y)
    		return x;
    	else if(y>=x&&y>=z)
    		return y;
    	else if(z>=x&&z>=y)
    		return z;
    }
    int main()
    {
    	for(int i = 1;i <= 3; i++)
    	{
    		scanf("%lf%lf%lf",&win[i],&tie[i],&lose[i]);
    		maxodd[i] = maxofthree(win[i],tie[i],lose[i]);
    		
    	}
    	for(int i = 1;i <= 3; i++){
    		if(win[i] >= tie[i] && win[i] >= lose[i])	{
    			printf("W ");
    		}
    		else if(tie[i] >= win[i]&&tie[i] >= lose[i])
    		{
    			printf("T ");
    		}
    		else if(lose[i] >= win[i]&&lose[i] >= tie[i])
    		{
    			printf("L ");
    		}
    	}
    	double ans = (maxodd[1]*maxodd[2]*maxodd[3]*0.65-1)*2;
    	printf("%.2lf",ans);
    	return 0;
    }
    

      

  • 相关阅读:
    如何解决js跨域问题
    Java Web系统常用的第三方接口
    webapi返回json格式,并定义日期解析格式
    华为手机打开Logcat的方法
    Kendo UI for ASP.NET MVC 的一些使用经验(转)
    adobe pro破解说明
    阿里云服务器添加解析域名
    tfs代码上传到server并下载到新位置
    kendo 级联加带搜索的下拉框以及js赋值
    函数进阶
  • 原文地址:https://www.cnblogs.com/qiangz/p/8447236.html
Copyright © 2011-2022 走看看