zoukankan      html  css  js  c++  java
  • Flight HDU

    Recently, Shua Shua had a big quarrel with his GF. He is so upset that he decides to take a trip to some other city to avoid meeting her. He will travel only by air and he can go to any city if there exists a flight and it can help him reduce the total cost to the destination. There's a problem here: Shua Shua has a special credit card which can reduce half the price of a ticket ( i.e. 100 becomes 50, 99 becomes 49. The original and reduced price are both integers. ). But he can only use it once. He has no idea which flight he should choose to use the card to make the total cost least. Can you help him?
    毕业了,乐乐打算去去旅行。目标城市已经定下来了,坐飞机前往。对于高中毕业生,航空公司有一项优惠政策,可以选一条线路半价,100变50,99变49。请你帮他设计一个方案,使得总花费最少。
    Input
    There are no more than 10 test cases. Subsequent test cases are separated by a blank line.
    The first line of each test case contains two integers N and M ( 2 <= N <= 100,000

    0 <= M <= 500,000 ), representing the number of cities and flights. Each of the following M lines contains "X Y D" representing a flight from city X to city Y with ticket price D ( 1 <= D <= 100,000 ). Notice that not all of the cities will appear in the list! The last line contains "S E" representing the start and end city. X, Y, S, E are all strings consisting of at most 10 alphanumeric characters.
    有多组测试数据 第一行两个整数n和m,表示n个城市和m条路线 接下来m行,每行表示一条路径,从x到y,花费s元 最后一行两个字符串,表示乐乐从发的起点和目标城市。
    Output
    One line for each test case the least money Shua Shua have to pay. If it's impossible for him to finish the trip, just output -1. 输出最少的花费,如果不能到达输出-1
    Sample Input
    4 4
    Harbin Beijing 500
    Harbin Shanghai 1000
    Beijing Chengdu 600
    Shanghai Chengdu 400
    Harbin Chengdu

    4 0
    Harbin Chengdu
    Sample Output
    800
    -1

    Hint
    In the first sample, Shua Shua should use the card on the flight from
    Beijing to Chengdu, making the route Harbin->Beijing->Chengdu have the
    least total cost 800. In the second sample, there's no way for him to get to
    Chengdu from Harbin, so -1 is needed.
    样例一中: Harbin->Beijing->Chengdu ,第二条路线使用半价

    题意:
    题面中有中文题意
    思路:
    是这题的低配版本https://www.cnblogs.com/qieqiemin/p/11298508.html

    这种都是套路题,在最短路dis的基础上多开一维维护使用了几次优惠的信息即可,转移就像dp一样。

    细节见代码:

    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <bits/stdc++.h>
    #include <cmath>
    #include <queue>
    #include <stack>
    #include <map>
    #include <set>
    #include <vector>
    #include <iomanip>
    #define ALL(x) (x).begin(), (x).end()
    #define sz(a) int(a.size())
    #define all(a) a.begin(), a.end()
    #define rep(i,x,n) for(int i=x;i<n;i++)
    #define repd(i,x,n) for(int i=x;i<=n;i++)
    #define pii pair<int,int>
    #define pll pair<long long ,long long>
    #define gbtb ios::sync_with_stdio(false),cin.tie(0),cout.tie(0)
    #define MS0(X) memset((X), 0, sizeof((X)))
    #define MSC0(X) memset((X), '', sizeof((X)))
    #define pb push_back
    #define mp make_pair
    #define fi first
    #define se second
    #define eps 1e-6
    #define gg(x) getInt(&x)
    #define chu(x) cout<<"["<<#x<<" "<<(x)<<"]"<<endl
    using namespace std;
    typedef long long ll;
    ll gcd(ll a, ll b) {return b ? gcd(b, a % b) : a;}
    ll lcm(ll a, ll b) {return a / gcd(a, b) * b;}
    ll powmod(ll a, ll b, ll MOD) {ll ans = 1; while (b) {if (b % 2)ans = ans * a % MOD; a = a * a % MOD; b /= 2;} return ans;}
    inline void getInt(int* p);
    const int maxn = 100010;
    const ll inf = 1e18;
    /*** TEMPLATE CODE * * STARTS HERE ***/
    struct node
    {
        int to;
        int kk;
        ll val;
        node(){}
        node(int tt,int ww,ll vv)
        {
            kk=ww;
            to=tt;
            val=vv;
        }
        bool operator < (const node & b) const
        {
            return val>b.val;
        }
    };
    std::vector<node> e[maxn];
    ll dis[maxn][15];
    unordered_map<string,int> info;
    void addedge(int a,int b,ll v)
    {
        e[a].push_back(node(b,0,v));
    }
    void init(int n)
    {
        for(int i=1;i<=n;++i)
        {
            for(int j=0;j<=2;j++)
                dis[i][j]=inf;
        }
    }
    priority_queue<node> heap;
    int n;
    int m,k=1;
    void dijkstra(int strat)
    {
        init(n);
        dis[strat][0]=0ll;
        heap.push(node(strat,0,0ll));
        node temp;
        while(!heap.empty())
        {
            temp=heap.top();
            heap.pop();
            int now=temp.to;
            ll val=temp.val;
            int kk=temp.kk;
            if(kk>k)
            {
                continue;
            }
            if(val>dis[now][kk])
                continue;
            for(auto x:e[now])
            {
                if(dis[x.to][kk]>val+x.val)
                {
                    dis[x.to][kk]=val+x.val;
                    heap.push(node(x.to,kk,dis[x.to][temp.kk]));
                }
                if(kk<k&&dis[x.to][temp.kk+1]>val+x.val/2)
                {
                    dis[x.to][kk+1]=val+x.val/2;
                    heap.push(node(x.to,kk+1,dis[x.to][temp.kk+1]));
                }
    
            }
        }
    }
    int main()
    {
        //freopen("D:\code\text\input.txt","r",stdin);
        //freopen("D:\code\text\output.txt","w",stdout);
        gbtb;
        while(cin>>n>>m)
        {
            info.clear();
            repd(i,1,n)
            {
                e[i].clear();
            }
            int u,v;ll c;
            string str1,str2;
            int cnt=0;
            while(m--)
            {
                cin>>str1>>str2>>c;
                if(info.count(str1)==0)
                {
                    info[str1]=++cnt;
                }
                if(info.count(str2)==0)
                {
                    info[str2]=++cnt;
                }
                u=info[str1];
                v=info[str2];
                addedge(u,v,c);
            }
            int s,t;
            cin>>str1>>str2;
            if(info.count(str1)==0)
            {
                info[str1]=++cnt;
            }
            if(info.count(str2)==0)
            {
                info[str2]=++cnt;
            }
            s=info[str1];
            t=info[str2];
            dijkstra(s);
            ll ans=inf;
            repd(i,0,1)
            {
                ans=min(ans,dis[t][i]);
            }
            if(ans==inf)
                ans=-1;
            cout<<ans<<endl;
        }
        return 0;
    }
    
    inline void getInt(int* p) {
        char ch;
        do {
            ch = getchar();
        } while (ch == ' ' || ch == '
    ');
        if (ch == '-') {
            *p = -(getchar() - '0');
            while ((ch = getchar()) >= '0' && ch <= '9') {
                *p = *p * 10 - ch + '0';
            }
        }
        else {
            *p = ch - '0';
            while ((ch = getchar()) >= '0' && ch <= '9') {
                *p = *p * 10 + ch - '0';
            }
        }
    }
    
    本博客为本人原创,如需转载,请必须声明博客的源地址。 本人博客地址为:www.cnblogs.com/qieqiemin/ 希望所写的文章对您有帮助。
  • 相关阅读:
    如何搭建docker镜像私有仓库
    CentOS 安装 Docker教程
    git push撤销、git commit 撤销、git add撤销、修改git提交信息
    虚拟对抗训练(VAT):一种用于监督学习和半监督学习的正则化方法
    CentOS7虚拟机配置、Hadoop搭建、wordCount DEMO运行
    统计学习方法——KD树K近邻搜索
    应用程序使用统计信息 – .NET CORE(C#) WPF界面设计
    (四)开源C# WPF控件库《AduSkin – UI》
    简化MVVM属性设置和修改
    少量代码设计一个登录界面(二) – .NET CORE(C#) WPF开发
  • 原文地址:https://www.cnblogs.com/qieqiemin/p/11298770.html
Copyright © 2011-2022 走看看