zoukankan      html  css  js  c++  java
  • 1029 Median (25分)

    iven an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

    Given two increasing sequences of integers, you are asked to find their median.

    Input Specification:

    Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

    Output Specification:

    For each test case you should output the median of the two given sequences in a line.

    Sample Input:

    4 11 12 13 14
    5 9 10 15 16 17
    
     

    Sample Output:

    13


    #include<iostream>
    using namespace std;
    
    int main()
    {
        int n,m;
        scanf("%d",&n);
        int a[n];
    
        for(int i=0;i<n;i++)//输入a
        {
            scanf("%d",&a[i]);
        }
    
        //输入b
        scanf("%d",&m);
        int b[m];
        for(int i=0;i<m;i++)
            scanf("%d",&b[i]);
    
        int i=0,j=0, mid=(n+m-1)/2;//如果将2个数组合二为一,新的数组下标是【0,m+n-1】,而i and j 是两个数组下标,所以要m+n-1,用来模拟合并的数组下标
    
        while(i+j<mid)
        {
            if(a[i]<=b[j])
                i++;
            else
                j++;
        }
    
        if(a[i]<b[j])
            printf("%d",a[i]);
        else
            printf("%d",b[j]);
    
        return 0;
    
    }
  • 相关阅读:
    软件工程第一周开课博客
    求数组的子数组之和的最大值
    学习进度_第二周
    当堂测试感受
    寒假生活体验
    家庭记账本七
    《人月神话》阅读笔记3
    家庭记账本六
    《人月神话》阅读笔记2
    寒假福利2
  • 原文地址:https://www.cnblogs.com/qinmin/p/12771291.html
Copyright © 2011-2022 走看看