zoukankan      html  css  js  c++  java
  • 第一次写结构体排序

    Supermarket

    Time Limit : 4000/2000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
    Total Submission(s) : 20   Accepted Submission(s) : 11
    Problem Description
    A supermarket has a set Prod of products on sale. It earns a profit px for each product x∈Prod sold by a deadline dx that is measured as an integral number of time units starting from the moment the sale begins. Each product takes precisely one unit of time for being sold. A selling schedule is an ordered subset of products Sell ≤ Prod such that the selling of each product x∈Sell, according to the ordering of Sell, completes before the deadline dx or just when dx expires. The profit of the selling schedule is Profit(Sell)=Σx∈Sellpx. An optimal selling schedule is a schedule with a maximum profit.
    For example, consider the products Prod={a,b,c,d} with (pa,da)=(50,2), (pb,db)=(10,1), (pc,dc)=(20,2), and (pd,dd)=(30,1). The possible selling schedules are listed in table 1. For instance, the schedule Sell={d,a} shows that the selling of product d starts at time 0 and ends at time 1, while the selling of product a starts at time 1 and ends at time 2. Each of these products is sold by its deadline. Sell is the optimal schedule and its profit is 80.

    Write a program that reads sets of products from an input text file and computes the profit of an optimal selling schedule for each set of products.
     
    Input
    A set of products starts with an integer 0 <= n <= 10000, which is the number of products in the set, and continues with n pairs pi di of integers, 1 <= pi <= 10000 and 1 <= di <= 10000, that designate the profit and the selling deadline of the i-th product. White spaces can occur freely in input. Input data terminate with an end of file and are guaranteed correct.
     
    Output
    For each set of products, the program prints on the standard output the profit of an optimal selling schedule for the set. Each result is printed from the beginning of a separate line.
     
    Sample Input
    4 50 2 10 1 20 2 30 1 7 20 1 2 1 10 3 100 2 8 2 5 20 50 10
     
    Sample Output
    80 185
     
    Source
    PKU
     
    贪心题,结构体排序;
     
     
    #include<stdio.h>
    #include<stdlib.h>
    struct profit
    {
     long p;
     long t;
    }pt[10001];
    int cmp(const void *a,const void *b)
    {
     return (*(struct profit *)b).p-(*(struct profit *)a).p;
    }
    int main()
    {
     long n,i,j,k,m,s,d[10001];
     while(scanf("%ld",&n)!=EOF)
     {
      for(i=0;i<n;i++)
       scanf("%ld%ld",&pt[i].p,&pt[i].t);
      qsort(pt,n,sizeof(pt[0]),cmp);
      for(i=0,m=0;i<n;i++)
       if(pt[i].t>m)
        m=pt[i].t;
      for(i=1;i<=m;i++)
       d[i]=0;
      for(i=0,s=0;i<n;i++)
       for(j=pt[i].t;j>0;j--)
        if(d[j]==0)
        {
         d[j]=1;
         s+=pt[i].p;
         break;
        }
      printf("%ld ",s);
     }
     return 0;
    }
  • 相关阅读:
    explain组合索引是否命中
    高并发优化
    docker基础篇一
    Web API 集成Serilog
    复习一下CSS,做笔记记录一下
    Process调用winform程序
    winform自动更新
    格式化xml 给没有节点的内容添加节点
    2.Grpc消息定义
    1.Grpc环境配置
  • 原文地址:https://www.cnblogs.com/qpddk/p/3214441.html
Copyright © 2011-2022 走看看