zoukankan      html  css  js  c++  java
  • HOJX 1003| Mixing Milk

    Problem Description

    Since milk packaging is such a low margin business, it is important to keep the price of the raw product (milk) as low as possible. Help Merry Milk Makers get the milk they need in the cheapest possible manner.

    The Merry Milk Makers company has several farmers from which they may buy milk, and each one has a (potentially) different price at which they sell to the milk packing plant. Moreover, as a cow can only produce so much milk a day, the farmers only have so much milk to sell per day. Each day, Merry Milk Makers can purchase an integral amount of milk from each farmer, less than or equal to the farmer's limit.

    Given the Merry Milk Makers' daily requirement of milk, along with the cost per gallon and amount of available milk for each farmer, calculate the minimum amount of money that it takes to fulfill the Merry Milk Makers' requirements.

    Note: The total milk produced per day by the farmers will be sufficient to meet the demands of the Merry Milk Makers.

    Input

    The first line contains two integers, N and M. The first value, N, (0 <= N <= 2,000,000) is the amount of milk that Merry Milk Makers' want per day. The second, M, (0 <= M <= 5,000) is the number of farmers that they may buy from.

    The next M lines (Line 2 through M+1) each contain two integers, Pi and Ai. Pi (0 <= Pi <= 1,000) is price in cents that farmer i charges. Ai (0 <= Ai <= 2,000,000) is the amount of milk that farmer i can sell to Merry Milk Makers per day.

    Output

    A single line with a single integer that is the minimum price that Merry Milk Makers can get their milk at for one day.

    Sample Input
    100 5
    
    5 20
    
    9 40
    
    3 10
    
    8 80
    
    6 30
    Sample Output
    630
    Time limit : 3 s
    Memory limit : 32 mb
    Submitted : 9962
    Accepted : 4313
     
    题意:这个题的意思是一个人要买数量为N(第一个输入)的牛奶,他从M(第二个输入)家里面挑,后面的输入就是这M家 :每一家牛奶单价 和 牛奶总数量。然后算一下要买到数量N的话,每一家都买多少才能花钱最少,输出花的钱数。
    思路:这是一个简单的贪心算法。解题思路就是先挑最便宜的买,看最便宜的这家的量有没有我要的这么多,要是没有的话,再去第二便宜的一家,进行同样的步骤。。。。
    代码:
    #include<iostream>
    #define FARMERS 5000
    using namespace std;
    int findMin(int *a,int n,bool *flag){
        int min=1001;
        int count;
        for(int i=0;i<n;i++){
            if(flag[i]==true)continue;
            if(a[i]<min){
                min=a[i];
                count=i;
            } 
            
        }
        flag[count]=true;
        return count;
    }
    int main(){
        bool flag[FARMERS]={false};
        int all,farmers;
        cin>>all>>farmers;
        int price[FARMERS],amount[FARMERS];
        int buy=0;
        for(int i=0;i<farmers;i++){
            cin>>price[i]>>amount[i];
        }
        while(all>0){
            int min=findMin(price,farmers,flag);
            int this_buy=amount[min];
            if(this_buy>all) this_buy=all;
            all-=this_buy;
            buy+=this_buy*price[min];
        }
        cout<<buy<<endl;
        return 0;
    }

    注:flag数组的作用是打标记。因为找到最便宜的一家之后,再找第二便宜的一家 正常的思路是找到最便宜的,买完后,删掉它。再再数组里找最小的,重复前面操作。但是考虑到删除数组中的一个元素是很麻烦的,所以采取了打标记的方式,其实就是把它当做已经删除了~

    findMin这个函数返回的是当前最便宜的那家的下标。变量all最初是他要买的牛奶总数,随着while循环不断迭代,all记录的就是还需要买的牛奶数量,直到它为0,就代表买完了。

  • 相关阅读:
    一剑走四方华山论剑
    本命年之冬去春来
    time of our lives从世界杯主题曲看厚脸皮的德国人:)
    我回来啦:)
    PHP undefined index的几种解决方法
    Nginx 502 Bad Gateway错误及解决方案收集
    Nginx Cache的5种方案
    PHP中ts和nts版本 vc6和vc9编译版本的区别
    Linux 查看连接数命令
    Nginx Proxy 作图片缓存配置文件
  • 原文地址:https://www.cnblogs.com/qq1337822982/p/10891655.html
Copyright © 2011-2022 走看看