zoukankan      html  css  js  c++  java
  • poj 1273 Drainage Ditches 网络流最大流基础

    Drainage Ditches
    Time Limit: 1000MS   Memory Limit: 10000K
    Total Submissions: 59176   Accepted: 22723

    Description

    Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.
    Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.
    Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.

    Input

    The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

    Output

    For each case, output a single integer, the maximum rate at which water may emptied from the pond.

    Sample Input

    5 4
    1 2 40
    1 4 20
    2 4 20
    2 3 30
    3 4 10
    

    Sample Output

    50

    //手打dinic,从我做起!
    //qscqesze
    #include <cstdio>
    #include <cmath>
    #include <cstring>
    #include <ctime>
    #include <iostream>
    #include <algorithm>
    #include <set>
    #include <vector>
    #include <sstream>
    #include <queue>
    #include <typeinfo>
    #include <fstream>
    #include <map>
    typedef long long ll;
    using namespace std;
    //freopen("D.in","r",stdin);
    //freopen("D.out","w",stdout);
    #define sspeed ios_base::sync_with_stdio(0);cin.tie(0)
    #define maxn 10000
    #define eps 1e-9
    const int inf=0x7fffffff;   //无限大
    //**************************************************************************************

    struct edge
    {
        int to,cap,rev;
    };
    vector<edge> g[maxn];
    int level[maxn];
    int iter[maxn];
    void add_edge(int from,int to,int cap)
    {
        g[from].push_back((edge){to,cap,g[to].size()});
        g[to].push_back((edge){from,0,g[from].size()-1});
    }
    void bfs(int s)
    {
        memset(level,-1,sizeof(level));
        queue<int> que;
        level[s]=0;
        que.push(s);
        while(!que.empty())
        {
            int v=que.front();
            que.pop();
            for(int i=0;i<g[v].size();i++)
            {
                edge &e=g[v][i];
                if(e.cap>0&&level[e.to]<0)
                {
                    level[e.to]=level[v]+1;
                    que.push(e.to);
                }
            }
        }
    }
    int dfs(int v,int t,int f)
    {
        if(v==t)return f;
        for(int &i=iter[v];i<g[v].size();i++)
        {
            edge &e=g[v][i];
            if(e.cap>0&&level[v]<level[e.to])
            {
                int d=dfs(e.to,t,min(f,e.cap));
                if(d>0)
                {
                    e.cap-=d;
                    g[e.to][e.rev].cap+=d;
                    return d;
                }
            }
        }
        return 0;
    }
    int max_flow(int s,int t)
    {
        int flow=0;
        while(1)
        {
            bfs(s);
            if(level[t]<0)return flow;
            memset(iter,0,sizeof(iter));
            int f;
            while((f=dfs(s,t,inf))>0)
                flow+=f;
        }
    }

    int main()
    {
        int n,m;
        while(cin>>n>>m)
        {
            for(int i=0;i<=m;i++)
                g[i].clear();
            int a,b,c;
            for(int i=0;i<n;i++)
            {
                cin>>a>>b>>c;
                add_edge(a,b,c);
            }
            cout<<max_flow(1,m)<<endl;
        }
    }

  • 相关阅读:
    爬虫-自动模拟http请求
    iOS开发 - 判断程序第一次开启 以及 应用升级后第一打开的判断
    NSDictionary的几种遍历方法
    算法回顾(三) 二分查找
    以前写的在wp7模拟器测试应用的测试框架
    iOS 应用开发基础翻译 改为 笔记和总结
    算法回顾(二):快速排序
    算法回顾(一):冒泡排序
    iOS 应用中的表视图(Table View)(译)
    预告:iOS 应用开发基础翻译
  • 原文地址:https://www.cnblogs.com/qscqesze/p/4314220.html
Copyright © 2011-2022 走看看