zoukankan      html  css  js  c++  java
  • HDU 4278 Faulty Odometer 8进制转10进制

    Faulty Odometer

    Time Limit: 20 Sec

    Memory Limit: 256 MB

    题目连接

    http://acm.hdu.edu.cn/showproblem.php?pid=4278

    Description

    You are given a car odometer which displays the miles traveled as an integer. The odometer has a defect, however: it proceeds from the digit 2 to the digit 4 and from the digit 7 to the digit 9, always skipping over the digit 3 and 8. This defect shows up in all positions (the one's, the ten's, the hundred's, etc.). For example, if the odometer displays 15229 and the car travels one mile, odometer reading changes to 15240 (instead of 15230).

    Input

    Each line of input contains a positive integer in the range 1..999999999 which represents an odometer reading. (Leading zeros will not appear in the input.) The end of input is indicated by a line containing a single 0. You may assume that no odometer reading will contain the digit 3 and 8.

    Output

    Each line of input will produce exactly one line of output, which will contain: the odometer reading from the input, a colon, one blank space, and the actual number of miles traveled by the car. 

    Sample Input

    15
    2005
    250
    1500
    999999
    0

    Sample Output

    15: 12
    2005: 1028
    250: 160
    1500: 768
    999999: 262143

    HINT

    题意

    有辆车的里程表坏了,3和8都不能显示,会直接跳过去,给你汽车里程表,输出实际跑了多远

    题解:

    8进制转10进制

    代码

    #include <cstdio>
    #include <cmath>
    #include <cstring>
    #include <ctime>
    #include <iostream>
    #include <algorithm>
    #include <set>
    #include <vector>
    #include <sstream>
    #include <queue>
    #include <typeinfo>
    #include <fstream>
    #include <map>
    #include <stack>
    typedef long long ll;
    using namespace std;
    //freopen("D.in","r",stdin);
    //freopen("D.out","w",stdout);
    #define sspeed ios_base::sync_with_stdio(0);cin.tie(0)
    #define test freopen("test.txt","r",stdin)
    const int maxn=2501;
    #define mod 1000000009
    #define eps 1e-7
    const int inf=0x3f3f3f3f;
    const ll infll = 0x3f3f3f3f3f3f3f3fLL;
    inline ll read()
    {
        ll x=0,f=1;char ch=getchar();
        while(ch<'0'||ch>'9'){if(ch=='-')f=-1;ch=getchar();}
        while(ch>='0'&&ch<='9'){x=x*10+ch-'0';ch=getchar();}
        return x*f;
    }
    //**************************************************************************************
    
    int d[8]={0,1,2,4,5,6,7,9};
    map<int,int> H;
    ll pow(ll x,ll y)
    {
        if(y==0)
            return 1;
        ll ans=1;
        for(int i=0;i<y;i++)
            ans*=x;
        return ans;
    }
    int main()
    {
        ll n;
        H[0]=0,H[1]=1,H[2]=2,H[4]=3,H[5]=4,H[6]=5,H[7]=6,H[9]=7;
        while(cin>>n)
        {
            if(n==0)
                break;
            printf("%lld: ",n);
            ll ans=0;
            ll t=0;
            while(n)
            {
                ans+=(H[n%10])*(pow(8,t++));
                n/=10;
            }
            cout<<ans<<endl;
        }
    }
  • 相关阅读:
    Grid如何固定列宽?
    ORACLE 去除重复记录
    Ajax学习之“一头雾水”
    对对碰方块交换及消去效果实现
    存储过程学习(二)
    asp.net 页面重用问题
    一个图表控件
    存储过程学习(一)
    ScriptManager.RegisterClientScriptBlock的疑问
    用indy做发贴机
  • 原文地址:https://www.cnblogs.com/qscqesze/p/4662212.html
Copyright © 2011-2022 走看看