zoukankan      html  css  js  c++  java
  • POJ 1743 Musical Theme 后缀数组 最长重复不相交子串

    Musical Theme
    Time Limit: 20 Sec

    Memory Limit: 256 MB

    题目连接

    http://poj.org/problem?id=1743

    Description

    A musical melody is represented as a sequence of N (1<=N<=20000)notes that are integers in the range 1..88, each representing a key on the piano. It is unfortunate but true that this representation of melodies ignores the notion of musical timing; but, this programming task is about notes and not timings.
    Many composers structure their music around a repeating &qout;theme&qout;, which, being a subsequence of an entire melody, is a sequence of integers in our representation. A subsequence of a melody is a theme if it: 
    • is at least five notes long 
    • appears (potentially transposed -- see below) again somewhere else in the piece of music 
    • is disjoint from (i.e., non-overlapping with) at least one of its other appearance(s)

    Transposed means that a constant positive or negative value is added to every note value in the theme subsequence. 
    Given a melody, compute the length (number of notes) of the longest theme. 
    One second time limit for this problem's solutions! 
     

    Input

    The input contains several test cases. The first line of each test case contains the integer N. The following n integers represent the sequence of notes. 
    The last test case is followed by one zero. 
     

    Output

    For each test case, the output file should contain a single line with a single integer that represents the length of the longest theme. If there are no themes, output 0.

    Sample Input

    30
    25 27 30 34 39 45 52 60 69 79 69 60 52 45 39 34 30 26 22 18
    82 78 74 70 66 67 64 60 65 80
    0

    Sample Output

    5

    HINT

    题意

    让你找到最长的不相交重复子串

    题解

    后缀数组,跑出height数组之后,然后直接二分然后O(n),check就好了

    代码:

    //qscqesze
    #include <cstdio>
    #include <cmath>
    #include <cstring>
    #include <ctime>
    #include <iostream>
    #include <algorithm>
    #include <set>
    #include <vector>
    #include <sstream>
    #include <queue>
    #include <typeinfo>
    #include <fstream>
    #include <map>
    #include <stack>
    typedef long long ll;
    using namespace std;
    //freopen("D.in","r",stdin);
    //freopen("D.out","w",stdout);
    #define sspeed ios_base::sync_with_stdio(0);cin.tie(0)
    #define maxn 25000
    #define mod 10007
    #define eps 1e-9
    int Num;
    char CH[20];
    //const int inf=0x7fffffff;   //нчоч╢С
    const int inf=0x3f3f3f3f;
    inline ll read()
    {
        int x=0,f=1;char ch=getchar();
        while(ch<'0'||ch>'9'){if(ch=='-')f=-1;ch=getchar();}
        while(ch>='0'&&ch<='9'){x=x*10+ch-'0';ch=getchar();}
        return x*f;
    }
    //**************************************************************************************
    
    int s[2*maxn];
    int a[maxn];
    int n;
    int sa[maxn], rank[maxn], height[maxn];
    int wa[maxn], wb[maxn], wv[maxn], wd[maxn];
    
    int cmp(int *r, int a, int b, int l){
        return r[a] == r[b] && r[a+l] == r[b+l];
    }
    
    void build_sa(int *r, int n, int m){          //  倍增算法 r为待匹配数组  n为总长度 m为字符范围
        int i, j, p, *x = wa, *y = wb, *t;
        for(i = 0; i < m; i ++) wd[i] = 0;
        for(i = 0; i < n; i ++) wd[x[i]=r[i]] ++;
        for(i = 1; i < m; i ++) wd[i] += wd[i-1];
        for(i = n-1; i >= 0; i --) sa[-- wd[x[i]]] = i;
        for(j = 1, p = 1; p < n; j *= 2, m = p){
            for(p = 0, i = n-j; i < n; i ++) y[p ++] = i;
            for(i = 0; i < n; i ++) if(sa[i] >= j) y[p ++] = sa[i] - j;
            for(i = 0; i < n; i ++) wv[i] = x[y[i]];
            for(i = 0; i < m; i ++) wd[i] = 0;
            for(i = 0; i < n; i ++) wd[wv[i]] ++;
            for(i = 1; i < m; i ++) wd[i] += wd[i-1];
            for(i = n-1; i >= 0; i --) sa[-- wd[wv[i]]] = y[i];
            for(t = x, x = y, y = t, p = 1, x[sa[0]] = 0, i = 1; i < n; i ++){
                x[sa[i]] = cmp(y, sa[i-1], sa[i], j) ? p - 1: p ++;
            }
        }
    }
    
    void calHeight(int *r, int n){           //  求height数组。
        int i, j, k = 0;
        for(i = 1; i <= n; i ++) rank[sa[i]] = i;
        for(i = 0; i < n; height[rank[i ++]] = k){
            for(k ? k -- : 0, j = sa[rank[i]-1]; r[i+k] == r[j+k]; k ++);
        }
    }
    int check(int mid)
    {
        int Minn=sa[0],Maxn=sa[0];
        for(int i=0;i<=n;i++)
        {
            if(height[i]>=mid)
            {
                Minn=min(sa[i],Minn);
                Maxn=max(sa[i],Maxn);
                if(Maxn-Minn>mid)
                    return 1;
            }
            else
                Minn=Maxn=sa[i];
        }
        return 0;
    }
    void init()
    {
        memset(a,0,sizeof(a));
        memset(s,0,sizeof(s));
        memset(sa,0,sizeof(sa));
        memset(rank,0,sizeof(rank));
        memset(height,0,sizeof(height));
        memset(wa,0,sizeof(wa));
        memset(wb,0,sizeof(wb));
        memset(wv,0,sizeof(wv));
        memset(wd,0,sizeof(wd));
    }
    int main()
    {
        while(cin>>n)
        {
            if(n==0)
                break;
            init();
            for(int i=0;i<n;i++)
                a[i]=read();
            n--;
            for(int i=0;i<n;i++)
                s[i]=a[i+1]-a[i]+100;
            s[n]=0;
            build_sa(s,n+1,200);
            calHeight(s,n);
            int l=0,r=n,ans=0;
            while(l<=r)
            {
                int mid=(l+r)>>1;
                if(check(mid))
                {
                    ans=max(ans,mid);
                    l=mid+1;
                }
                else
                    r=mid-1;
            }
            if(ans<4)
                ans=0;
            else
                ans++;
            cout<<ans<<endl;
        }
    }
  • 相关阅读:
    热修复之类加载机制总结
    socket之tcp如何维护长连接
    sqlite之多线程处理
    android主线程ActivityThread-转载
    线程之ThreadLocal使用
    图片之压缩总结
    线程之交替执行的实例
    git的最常用命令总结
    sqlite之常见的语句
    activity之分析-3分钟看懂Activity启动流程
  • 原文地址:https://www.cnblogs.com/qscqesze/p/4719232.html
Copyright © 2011-2022 走看看