zoukankan      html  css  js  c++  java
  • HDU 4813 Hard Code 水题

    Hard Code

    Time Limit: 1 Sec  

    Memory Limit: 256 MB

    题目连接

    http://acm.hust.edu.cn/vjudge/contest/view.action?cid=95149#problem/A

    Description

    Some strange code is sent to Da Shan High School. It's said to be the prophet's note. The note is extremely hard to understand. However, Professor Meng is so smart that he successfully found the pattern of the code. That is, the length of the code is the product of two prime numbers. He tries to reallocate the code into a grid of size N*M, where M is the bigger prime. In specific, he writes down the letters of the code to the cells one by one, from left to right, and from top to button. In this way, he found the code eventually readable.

    Professor Meng wants to know all the secrets of the note right now. But he doesn't take his computer with him. Can you help him?

    Input

    The first line of the input is L (L ≤ 1000), which means the number of test cases.

    For each test case, the first line contains two prime numbers, which indicates N, M (0 < N * M ≤ 1000) as describe above. The second line contains a string, i.e., the code, containing only lowercase letters. It’s guaranteed the length of the string equals to N * M.
    The first line of the input is L (L ≤ 1000), which means the number of test cases.

    For each test case, the first line contains two prime numbers, which indicates N, M (0 < N * M ≤ 1000) as describe above. The second line contains a string, i.e., the code, containing only lowercase letters. It’s guaranteed the length of the string equals to N * M.
     
    Ci​​,即此题的初始分值、每分钟减少的分值、dxy做这道题需要花费的时间。

    Output

    For each test case, output N lines, each line with M letters representing the readable code after the reallocation.

    Sample Input

    1 2 5 klmbbileay

    Sample Output

    klmbb ileay

    HINT

    题意

    给你一个字符串,然后变成n*m的矩阵

    题解:

    水题啦

    代码:

    #include<stdio.h>
    #include<iostream>
    using namespace std;
    
    string s;
    int main()
    {
        int t;
        scanf("%d",&t);
        while(t--)
        {
            int n,m;scanf("%d%d",&n,&m);
            cin>>s;
            for(int i=0;i<s.size();i++)
            {
                cout<<s[i];
                if((i+1)%m==0)
                    cout<<endl;
            }
        }
    }
  • 相关阅读:
    angular转场动画
    css常用单位
    css3美化滚动条样式
    grid布局
    angular使用material组件库和tailwindcss样式
    使用 BaGet 搭建 nuget 仓库
    net core api 文件下载,断点续传
    netcore 使用中间件响应文件下载请求
    angular通知组件--angular2-toaster
    angular图标组件--@visurel/iconify-angular
  • 原文地址:https://www.cnblogs.com/qscqesze/p/4877933.html
Copyright © 2011-2022 走看看