zoukankan      html  css  js  c++  java
  • HDU 5289 Assignment rmq

    Assignment

    题目连接:

    http://acm.hdu.edu.cn/showproblem.php?pid=5289

    Description

    Tom owns a company and he is the boss. There are n staffs which are numbered from 1 to n in this company, and every staff has a ability. Now, Tom is going to assign a special task to some staffs who were in the same group. In a group, the difference of the ability of any two staff is less than k, and their numbers are continuous. Tom want to know the number of groups like this.

    Input

    In the first line a number T indicates the number of test cases. Then for each case the first line contain 2 numbers n, k (1<=n<=100000, 0<k<=10^9),indicate the company has n persons, k means the maximum difference between abilities of staff in a group is less than k. The second line contains n integers:a[1],a[2],…,an,indicate the i-th staff’s ability.

    Output

    For each test,output the number of groups.

    Sample Input

    2
    4 2
    3 1 2 4
    10 5
    0 3 4 5 2 1 6 7 8 9

    Sample Output

    5
    28

    Hint

    题意

    给你n个数,然后连续的,且这个区间内最大值减去最小值的差小于k的话,就可以算作一队。

    问你一共有多少种分队的方法。

    题解:

    暴力枚举左端点位置,然后二分枚举右端点,用一个rmq维护一下就好了。

    代码

    #include<bits/stdc++.h>
    using namespace std;
    const int maxn = 1e5+7;
    struct RMQ{
        const static int RMQ_size = maxn;
    	int n;
    	int ArrayMax[RMQ_size][21];
    	int ArrayMin[RMQ_size][21];
    
    	void build_rmq(){
    		for(int j = 1 ; (1<<j) <= n ; ++ j)
    			for(int i = 0 ; i + (1<<j) - 1 < n ; ++ i){
    				ArrayMax[i][j]=max(ArrayMax[i][j-1],ArrayMax[i+(1<<(j-1))][j-1]);
    				ArrayMin[i][j]=min(ArrayMin[i][j-1],ArrayMin[i+(1<<(j-1))][j-1]);
    			}
    	}
    
    	int QueryMax(int L,int R){
    		int k = 0;
    		while( (1<<(k+1)) <= R-L+1) k ++ ;
    		return max(ArrayMax[L][k],ArrayMax[R-(1<<k)+1][k]);
    	}
    
    	int QueryMin(int L,int R){
    		int k = 0;
    		while( (1<<(k+1)) <= R-L+1) k ++ ;
    		return min(ArrayMin[L][k],ArrayMin[R-(1<<k)+1][k]);
    	}
    
    
    	void init(int * a,int sz){
    		n = sz ;
    		for(int i = 0 ; i < n ; ++ i) ArrayMax[i][0] = ArrayMin[i][0] = a[i];
    		build_rmq();
    	}
    
    }solver;
    int a[maxn];
    int main()
    {
        int t;
        scanf("%d",&t);
        while(t--)
        {
            int n,k;scanf("%d%d",&n,&k);
            for(int i=0;i<n;i++)
                scanf("%d",&a[i]);
            solver.init(a,n);
            long long ans = 0;
            for(int i=0;i<n;i++)
            {
                int l = i,r = n-1,Ans=i;
                while(l<=r)
                {
                    int mid = (l+r)/2;
                    if(solver.QueryMax(i,mid)-solver.QueryMin(i,mid)<k)l=mid+1,Ans=mid;
                    else r=mid-1;
                }
                ans += (Ans-i+1);
            }
            cout<<ans<<endl;
        }
    	return 0;
    }
  • 相关阅读:
    TranslateAnimation详解
    商业价值:谷歌娱乐影音之路上的硬件产品
    红黑树源码实现
    cocos2d-x Loading界面实现资源加载
    Android String 转 MD5
    [置顶] 【原创分享】嵌入式linux应用之内核移植定制篇-前篇(linux-3.8.12 mini2440)--20130824
    搭建Windows故障转移群集
    ,典型递归问题-F(1025)mod 5 的值
    android:为TextView加入样式——下划线,颜色,设置链接样式及前背景色
    现在仍在工作的12名最“屌”的程序猿
  • 原文地址:https://www.cnblogs.com/qscqesze/p/5269577.html
Copyright © 2011-2022 走看看