zoukankan      html  css  js  c++  java
  • URAL 1991 The battle near the swamp 水题

    The battle near the swamp

    题目连接:

    http://acm.timus.ru/problem.aspx?space=1&num=1991

    Description

    Gungan: Jar Jar, usen da booma!
    Jar Jar: What? Mesa no have a booma!
    Gungan: Here. Taken dis one.
    In the battle with the Trade Federation, Queen Amidala decided to ask gungans for help. Jar Jar Binks escorted the Queen and her people to the holy place where they had an agreement. The gungans agreed to provide their army in order to get the droids of the Federation out from the capital. The gungan ruler Boss Nass was so grateful for uniting the nations that he appointed Jar Jar a general.
    And here they are: two armies lined up along the bank of the swamp. The droids of the Federation are well-disciplined soldiers. They stand in neat formation, divided into n blocks of k droids each. The gungans have a foolproof weapon against droids, which is small energy balls called boom booms. One such ball can disable exactly one droid.
    Jar Jar Binks also decided to split his army into n parts and give each part a task to destroy the corresponding block of droids. Each part received a truck with boom booms. Now help general Binks calculate the number of boom booms that will be left unused and the number of droids that will survive the attack. You can assume that when a boom boom is fired at a droid by a gungan, it always hits the target.

    Input

    The first line of the input contains numbers n and k (1 ≤ n, k ≤ 10 000). The second line contains n numbers ai (0 ≤ ai ≤ 100 000) — the number of boom-booms in the i-th truck.

    Output

    Print two integers — the number of unused boom booms and the number of survived droids.

    Sample Input

    4 5
    2 7 5 0

    Sample Output

    2 8

    Hint

    题意

    有n块,每块有k个怪物

    然后每一块有ai个武器

    问你最后剩下多少个武器,以及多少个怪物没有消灭

    题解:

    水题……

    代码

    #include<bits/stdc++.h>
    using namespace std;
    
    int main()
    {
        int n;
    	long long k;
    	cin>>n>>k;
    	long long ans1 = 0,ans2 = 0;
    	for(int i=1;i<=n;i++)
    	{
    		long long x;
    		cin>>x;
    		if(x>k)ans1+=x-k;
    		if(k>x)ans2+=k-x;
    	}
    	cout<<ans1<<" "<<ans2<<endl;
    }
  • 相关阅读:
    js之数组的方法
    js之选项卡
    js之数据类型的比较
    Android sharedUserId研究记录
    直接拿来用!最火的Android开源项目(一)
    [转]简约而不简单——Android SimpleAdapter
    [转]Android GC机制及一些调试信息
    sendToTarget 和 sendMessage 区别
    Android中内容观察者的使用---- ContentObserver类详解 (转)
    Inflate()
  • 原文地址:https://www.cnblogs.com/qscqesze/p/5370266.html
Copyright © 2011-2022 走看看