zoukankan      html  css  js  c++  java
  • URAL 1993 This cheeseburger you don't need 模拟题

    This cheeseburger you don't need

    题目连接:

    http://acm.timus.ru/problem.aspx?space=1&num=1993

    Description

    Master Yoda is the oldest member of the Jedi Council. He conducts preparatory classes of little Younglings up to the moment they get a mentor. All Younglings adore master Yoda and they hope to grow as strong and wise as he is. Just like all little children, Younglings are absolutely hooked on new games and ideas. Now they decided to learn to speak just like master Yoda. Help the Younglings understand how Yoda would say this or that sentence.
    Yoda is speaking the Galactic language using the specific word order — so-called "object-subject-verb".
    Your program receives a sentence that interests the Younglings. They have already highlighted all important parts in the sentence. They use the curly {}-brackets for objects, round ()-brackets for subjects and square []-brackets for verbs.
    A sentence in the input can be simple or complex. If the sentence is complex, then it consists of two simple sentences separated by a comma. Sometimes a comma is followed by a conjunction that is not in the brackets.
    Each simple question has exactly one object, one subject and one verb. Your task is to simply put them in the correct order. Namely, first the object, then the subject, finally the verb. Also, please do not forget that only the first word in the whole sentence should begin with capital letter.

    Input

    The single line contains a sentence that interests the Younglings. The length of the sentence does not exceed 100 characters. All the words in the sentence consist of Latin letters. The first letter of the first word is capitalized and the rest are small. The sentence may contain a comma. Each simple sentence contains all three types of brackets. Each pair of brackets surrounds one or more words. No pair of brackets can surround the other bracket. Brackets are always located on the borders of words. The words in the sentence are separated by a single space. There is no space character before a comma or a closing bracket and also after an opening bracket. The conjunction (which can be only after a comma) is the only word that is not surrounded by a pair of brackets.

    Output

    Print the sentence with the word order Yoda would use. All brackets must be omitted. You should separate the words by a single space.

    Sample Input

    (We) [are] {blind}, if (we) [could not see] {creation of this clone army}

    Sample Output

    Blind we are, if creation of this clone army we could not see

    Hint

    题意

    没括号的原样输出,有括号的就优先输出大括号,中括号,然后小括号这样

    句首需要大写

    题解:

    模拟题,烦……

    代码

    #include <bits/stdc++.h>
    
    using namespace std;
    
    string base;
    vector < string > str;
    
    string Clear_32(string s){
        string res;
    	int Ed = s.size() - 1;
    	for( ; Ed >= 0 && s[Ed] == ' ' ; -- Ed);
    	for(int i = 0 ; i < s.size() ; ++ i){
    		if( s[i] != ' '){
    			for(int j = i ; j <= Ed ; ++ j) res.push_back( s[j] );
    			break;
    		}
    	}
    	return res;
    }
    
    void Solve( string s , int INDEX ){
    	stack < int > sp;
    	string F[4];
    	int pos[4];
    	F[0]=F[1]=F[2]=F[3]="";
    	bool find = false;
    	for(int i = 0 ; i < s.size() ; ++ i){
    		if(s[i] == '[' || s[i] == '(' || s[i] == '{'){
    			sp.push( i );
    			if( find == false ) F[0]=s.substr(0,i);
    			find = true;
    			if(s[i] == '{') pos[1] = i;
    			else if(s[i] =='(') pos[2] = i;
    			else pos[3] = i;
    		}
    		else if(s[i] == ']' || s[i] == ')' || s[i] == '}'){
    			string * ptr = F;
    			int extra = 0;
    			if( s[i] == '}' ) extra = 1;
    			else if( s[i] == ')' ) extra=2;
    			else extra=3;
    			ptr += extra;
    			*ptr=s.substr(pos[extra]+1,i-pos[extra]-1);
    		} 
    	}
    	for(int i = 1 ; i < 4 ; ++ i) F[i] = Clear_32( F[i] );
    	cout << F[0];
        if(INDEX==0){
        	for(int i = 0 ; i < 4 ; ++ i)
        		if(F[i].size()){
        			if(F[i][0] <= 'z' && F[i][0] >='a'){
        				F[i][0] = F[i][0] - 'a' + 'A';
        			}
        			for(int j = 1 ; j < F[i].size() ; ++ j){
        				if(F[i][j] <= 'Z' && F[i][j] >= 'A'){
        					F[i][j] = F[i][j] - 'A' + 'a';
        				}
        			}
        			for(int k = i + 1 ; k < 4 ; ++ k){
        				for(int v = 0 ; v < F[k].size() ; ++ v){
    	    				if(F[k][v] <= 'Z' && F[k][v] >= 'A'){
    	    					F[k][v] = F[k][v] - 'A' + 'a';
    	    				}
        				}
        			}
        			break;
        		}
        }
        int isfirst = 0;
        for(int i = 1 ; i < 4 ; ++ i){
        	if(F[i].size()){
        		if(isfirst==0) isfirst = 1;
        		else cout << " ";
        		cout << F[i];
        	}
        }
    }
    
    int main(int argc,char *argv[]){
    //	freopen("out.txt" , "w" , stdout );
    	getline(cin , base);
    	for(int i = 0 ; i < base.size() ; ++ i){
    		int j;
    		string temp;
    		for(j = i ; j < base.size() ; ++ j){
    			if( base[j] ==',' && i != j ) break;
    			temp.push_back( base[j] );
    		}
    		str.push_back( temp );
    		i = j - 1;
    	}
    	for(int i = 0 ; i < str.size() ; ++ i) Solve( str[i] , i );
    	cout << endl;
    	return 0;
    }
  • 相关阅读:
    把自己活成AI
    cmd 中文显示错误,解决办法
    直流通路,交流通路的理解 三极管
    欧拉公式的理解
    从一个量分别和两个量成正比,怎么推理出和他们乘积成正比?
    细说python类3——类的创建过程
    delphi 基础之二 面向对象概念初步
    delphi 基础之一 数据类型和基本语法
    delphi的多线程编程
    Delphi初学者应小心的六大陷阱
  • 原文地址:https://www.cnblogs.com/qscqesze/p/5370297.html
Copyright © 2011-2022 走看看