zoukankan      html  css  js  c++  java
  • poj 2182,乱搞

    D - Lost Cows
    Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u

    Description

    N (2 <= N <= 8,000) cows have unique brands in the range 1..N. In a spectacular display of poor judgment, they visited the neighborhood 'watering hole' and drank a few too many beers before dinner. When it was time to line up for their evening meal, they did not line up in the required ascending numerical order of their brands.

    Regrettably, FJ does not have a way to sort them. Furthermore, he's not very good at observing problems. Instead of writing down each cow's brand, he determined a rather silly statistic: For each cow in line, he knows the number of cows that precede that cow in line that do, in fact, have smaller brands than that cow.

    Given this data, tell FJ the exact ordering of the cows.

    Input

    * Line 1: A single integer, N

    * Lines 2..N: These N-1 lines describe the number of cows that precede a given cow in line and have brands smaller than that cow. Of course, no cows precede the first cow in line, so she is not listed. Line 2 of the input describes the number of preceding cows whose brands are smaller than the cow in slot #2; line 3 describes the number of preceding cows whose brands are smaller than the cow in slot #3; and so on.

    Output

    * Lines 1..N: Each of the N lines of output tells the brand of a cow in line. Line #1 of the output tells the brand of the first cow in line; line 2 tells the brand of the second cow; and so on.

    Sample Input

    5
    1
    2
    1
    0
    

    Sample Output

    2
    4
    5
    3
    1
    
    #include<iostream>
    #define N 8005
    using namespace std;
    
    
    struct NODE{
        int l,r,num;
    }node[N<<2];
    
    int n,ocr[N];
    
    void build(int i,int left,int right){
        node[i].l=left;
        node[i].r=right;
        node[i].num=right-left+1;
        if(right>left){
            int mid=(right+left)>>1;
            i=i<<1;
            build(i,left,mid);
            build(i+1,mid+1,right);
        }
    }
    
    void findBrand(int i,int c,int j){
        if(node[i].l==node[i].r){
            node[i].num=0;
            ocr[j]=node[i].l;
            return;
        }
        node[i].num--;
        i=i<<1;
        if(node[i].num>=c) findBrand(i,c,j);
        else{
            c-=node[i].num;
            findBrand(i+1,c,j);
        }
    }
    
    int main(){
        int i;
        while(cin>>n){
            build(1,1,n);
            for(i=1;i<n;i++)cin>>ocr[i];
            for(i=n-1;i>-1;i--)findBrand(1,ocr[i]+1,i);
            for(i=0;i<n;i++)cout<<ocr[i]<<endl;
        }
        return 0;
    }
    
  • 相关阅读:
    Azure ARM (8) ARM Template
    Azure ARM (7) ARM Template
    Azure ARM (6) ARM Template简单介绍
    HBase集群安装过程中的问题集锦
    修改linux最大文件句柄数
    Hadoop 2.2.0部署安装(笔记,单机安装)
    sqoop安装部署(笔记)
    HIVE部署安装(笔记)
    防盗链Nginx设置图片防盗链,设置无效的请仔细看红字
    postgresql 内存分配
  • 原文地址:https://www.cnblogs.com/ramanujan/p/3413043.html
Copyright © 2011-2022 走看看