zoukankan      html  css  js  c++  java
  • 7-1 Hashing

    The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

    Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

    Input Specification:

    Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (<=104) and N (<=MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space. MSize (<=104) and N (<=MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.​​) and N (MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

    Output Specification:

    For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print "-" instead.

    Sample Input:

    4 4
    10 6 4 15
     

    Sample Output:

    0 1 4 -

    题目大意:

    给出大小为m的哈希表长,以及n个数。要求将元素按读入的顺序插入至哈希表中,并用二次探测法解决冲突问题,如果冲突无法解决则输出 -

    解决思路:

    先解决表长不为素数的问题,再解决哈希表的插入问题,二次探测法的公式为 (key + step * step) % size,该题最后会卡一下空格输出的格式

    代码实现:

    #include<iostream>
    using namespace std;
    int n,size;
    int temp;
    bool judge[10100]={false};
    void cubeinsert(int key)
    {
        for(int i = 0; i < size; i ++)
        {
            int index = (key + i * i) % size;//二次探测法公式(key + step * step) % size 
            if(!judge[index])
            {
                cout<<index;
                judge[index] = true;
                return;
            }
        }
        cout<<'-';
    }
    bool isprime(int n)//判断素数 
    {
        if (n <= 1) return false;
        for (int i = 2; i * i <= n; i++)
            if (n % i == 0) return false;
        return true;
    }
    int main()
    {
        cin>>size>>n;
        while(!isprime(size))
        {
            size++;
        }
        
        for(int i = 0; i < n; i ++)
        {
            cin>>temp;
            if(i != 0) cout << ' ';//测试卡输出格式 
            cubeinsert(temp);
        }
        return 0;
    }
     
     
  • 相关阅读:
    sqlParameter的两种写法 以及存储过程还有sql语句(防注入)
    SqlServer2005 SQL Server 版本变更检查 警告
    禁用自带防火墙
    sql分页
    每个程序员都必须遵守的编程原则
    在PDA设备上安装SQL Server Compact
    Mcrosoft SQL Server 自定义函数
    程序员人生之路(转)
    在windows 7 上为 sqlserver 2008 启用远程访问
    在PDA设备上安装和部署 SQL Server Compac 3.5(官方版)
  • 原文地址:https://www.cnblogs.com/rebloom000/p/14063270.html
Copyright © 2011-2022 走看看