zoukankan      html  css  js  c++  java
  • UVa 100 The 3n + 1 problem

    The 3n + 1 problem

    Background

    Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive).  In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs.

    The Problem

    Consider the following algorithm:

     1. input n

    2. print n

    3. if n= 1 then STOP

    4. if n is odd then n=3n+1

    5. else n=n/2

    6. GOTO 2

    Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1

    It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value.  Despite the simplicity of the algorithm, it is unknown whether this conjecture is true.  It has been verified, however, for all integers n such that 0 < n< 1,000,000 (and, in fact, for many more numbers than this.)

    Given an input n, it is possible to determine the number of numbers printed (including the 1).  For a given n this is called the cycle-length of n.  In the example above, the cycle length of 22 is 16.

    For any two numbers i and j you are to determine the maximum cycle length over all numbers between i andj.

    The Input

    The input will consist of a series of pairs of integers i and j, one pair of integers per line.  All integers will be less than 1,000,000 and greater than 0.

    You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j.

    You can assume that no operation overflows a 32-bit integer.

    The Output

    For each pair of input integers i and j you should output i, j, and the maximum cycle length for integers between and includingi and j.  These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input.  The integersi and jmust appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line).

    Sample Input

    1 10
    100 200
    201 210
    900 1000
    

    Sample Output

    1 10 20
    100 200 125
    201 210 89
    900 1000 174
    
    源代码:

    #include<iostream>

    using namespace std;

    int main()

    {

        int i,j,sum1,sum2;

        while(cin>>i>>j)

        {

            cout<<i<<" "<<j<<" ";

            if(i>j)

                swap(i,j);//注意

            sum2=0;

            for(int n=i;n<=j;++n)

            {

                int m=n;

                sum1=1;

                while(m!=1)

                {

                    m%2==0?m/=2:m=3*m+1;

                    sum1++;

                }

                if(sum1>sum2) sum2=sum1;

            }

            cout<<sum2<<endl;

        }

        return 0;

                

    }

     

  • 相关阅读:
    HDU 6370 dfs+并查集
    牛客网暑期ACM多校训练营(第六场)G
    HDU 6351暴力枚举 6354计算几何
    2018 ACM 国际大学生程序设计竞赛上海大都会赛重现赛 A,D
    2018 百度之星 初赛 第六题 HDU6349
    HDU 6336 子矩阵求和
    HDU 6333 莫队+组合数
    BZOJ 2308 莫队入门经典
    Linux系统管理第一章
    2019年7月17日
  • 原文地址:https://www.cnblogs.com/redlight/p/2291345.html
Copyright © 2011-2022 走看看