zoukankan      html  css  js  c++  java
  • poj2774之最长公共子串

    Long Long Message
    Time Limit: 4000MS   Memory Limit: 131072K
    Total Submissions: 18794   Accepted: 7744
    Case Time Limit: 1000MS

    Description

    The little cat is majoring in physics in the capital of Byterland. A piece of sad news comes to him these days: his mother is getting ill. Being worried about spending so much on railway tickets (Byterland is such a big country, and he has to spend 16 shours on train to his hometown), he decided only to send SMS with his mother. 

    The little cat lives in an unrich family, so he frequently comes to the mobile service center, to check how much money he has spent on SMS. Yesterday, the computer of service center was broken, and printed two very long messages. The brilliant little cat soon found out: 

    1. All characters in messages are lowercase Latin letters, without punctuations and spaces. 
    2. All SMS has been appended to each other – (i+1)-th SMS comes directly after the i-th one – that is why those two messages are quite long. 
    3. His own SMS has been appended together, but possibly a great many redundancy characters appear leftwards and rightwards due to the broken computer. 
    E.g: if his SMS is “motheriloveyou”, either long message printed by that machine, would possibly be one of “hahamotheriloveyou”, “motheriloveyoureally”, “motheriloveyouornot”, “bbbmotheriloveyouaaa”, etc. 
    4. For these broken issues, the little cat has printed his original text twice (so there appears two very long messages). Even though the original text remains the same in two printed messages, the redundancy characters on both sides would be possibly different. 

    You are given those two very long messages, and you have to output the length of the longest possible original text written by the little cat. 

    Background: 
    The SMS in Byterland mobile service are charging in dollars-per-byte. That is why the little cat is worrying about how long could the longest original text be. 

    Why ask you to write a program? There are four resions: 
    1. The little cat is so busy these days with physics lessons; 
    2. The little cat wants to keep what he said to his mother seceret; 
    3. POJ is such a great Online Judge; 
    4. The little cat wants to earn some money from POJ, and try to persuade his mother to see the doctor :( 

    Input

    Two strings with lowercase letters on two of the input lines individually. Number of characters in each one will never exceed 100000.

    Output

    A single line with a single integer number – what is the maximum length of the original text written by the little cat.

    Sample Input

    yeshowmuchiloveyoumydearmotherreallyicannotbelieveit
    yeaphowmuchiloveyoumydearmother
    

    Sample Output

    27
    #include <iostream>
    #include <cstdio>
    #include <cstdlib>
    #include <cstring>
    #include <string>
    #include <queue>
    #include <algorithm>
    #include <map>
    #include <iomanip>
    #define INF 99999999
    typedef long long LL;
    using namespace std;
    
    const int MAX=2*100000+10;
    int *rank,r[MAX],sa[MAX],height[MAX];
    int wa[MAX],wb[MAX],wm[MAX];
    char s[MAX];
    
    bool cmp(int *r,int a,int b,int l){
    	return r[a] == r[b] && r[a+l] == r[b+l];
    }
    
    void makesa(int *r,int *sa,int n,int m){
    	int *x=wa,*y=wb,*t;
    	for(int i=0;i<m;++i)wm[i]=0;
    	for(int i=0;i<n;++i)wm[x[i]=r[i]]++;
    	for(int i=1;i<m;++i)wm[i]+=wm[i-1];
    	for(int i=n-1;i>=0;--i)sa[--wm[x[i]]]=i;
    	for(int i=0,j=1,p=0;p<n;j=j*2,m=p){
    		for(p=0,i=n-j;i<n;++i)y[p++]=i;
    		for(i=0;i<n;++i)if(sa[i]>=j)y[p++]=sa[i]-j;
    		for(i=0;i<m;++i)wm[i]=0;
    		for(i=0;i<n;++i)wm[x[y[i]]]++;
    		for(i=1;i<m;++i)wm[i]+=wm[i-1];
    		for(i=n-1;i>=0;--i)sa[--wm[x[y[i]]]]=y[i];
    		for(t=x,x=y,y=t,i=p=1,x[sa[0]]=0;i<n;++i){
    			x[sa[i]]=cmp(y,sa[i],sa[i-1],j)?p-1:p++;
    		}
    	}
    	rank=x;
    }
    
    void calheight(int *r,int *sa,int n){
    	for(int i=0,j=0,k=0;i<n;height[rank[i++]]=k){
    		for(k?--k:0,j=sa[rank[i]-1];r[i+k] == r[j+k];++k);
    	}
    }
    
    int main(){
    	while(~scanf("%s",s)){
    		int n=0,len,sum=0;
    		for(n=0;s[n] != '';++n)r[n]=s[n];
    		r[len=n]='#';
    		scanf("%s",s+n+1);//将输入的两个字符串连接在一起,中间用'#'隔开
    		for(++n;s[n] != '';++n)r[n]=s[n];
    		r[n]=0;
    		makesa(r,sa,n+1,256);
    		calheight(r,sa,n);
    		for(int i=1;i<=n;++i){
    			if(min(sa[i],sa[i-1])<len && max(sa[i],sa[i-1])>len)sum=max(sum,height[i]);
    		}
    		cout<<sum<<endl;
    	}
    	return 0;
    }
  • 相关阅读:
    C#基础系列——一场风花雪月的邂逅:接口和抽象类
    C#进阶系列——动态Lamada(二:优化)
    C#进阶系列——动态Lamada
    JS组件系列——Bootstrap Table 表格行拖拽(二:多行拖拽)
    JS组件系列——Bootstrap Table 表格行拖拽
    C#进阶系列——DDD领域驱动设计初探(七):Web层的搭建
    C#进阶系列——MEF实现设计上的“松耦合”(四):构造函数注入
    C#进阶系列——DDD领域驱动设计初探(六):领域服务
    C#进阶系列——DDD领域驱动设计初探(五):AutoMapper使用
    C#进阶系列——DDD领域驱动设计初探(四):WCF搭建
  • 原文地址:https://www.cnblogs.com/riasky/p/3429155.html
Copyright © 2011-2022 走看看