zoukankan      html  css  js  c++  java
  • 关于 图论·并查集·HDU1232&1856

         其核心是追溯其根数和链接两个数,而HDU 1856要多一步,每一个根数要标记自己和自己子数的个数,因此用结构体。注意:1856 用C写没超时,用C++写超时了╮(╯﹏╰)╭

     接下来是题目和代码:

    畅通工程

    Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 22006    Accepted Submission(s): 11457

    Problem Description 某省调查城镇交通状况,得到现有城镇道路统计表,表中列出了每条道路直接连通的城镇。省政府“畅通工程”的目标是使全省任何两个城镇间都可以实现交通(但不一定有直接的道路相连,只要互相间接通过道路可达即可)。问最少还需要建设多少条道路?  

    Input 测试输入包含若干测试用例。每个测试用例的第1行给出两个正整数,分别是城镇数目N ( < 1000 )和道路数目M;随后的M行对应M条道路,每行给出一对正整数,分别是该条道路直接连通的两个城镇的编号。为简单起见,城镇从1到N编号。 注意:两个城市之间可以有多条道路相通,也就是说 3 3 1 2 1 2 2 1 这种输入也是合法的 当N为0时,输入结束,该用例不被处理。  

    Output 对每个测试用例,在1行里输出最少还需要建设的道路数目。  

    Sample Input 4 2 1 3 4 3 3 3 1 2 1 3 2 3 5 2 1 2 3 5 999 0 0  

    Sample Output 1 0 2 998

    #include<iostream>
    using namespace std;
    int father[1100],sum;
    int find(int a)
    {
     while(a!=father[a])//这个地方只能用while ,不能用if,while循环,找到最初的father.
      a=father[a];
     return a;
    }
    void join(int a,int b)
    {
     int x=find(a),y=find(b);  //追溯其根数
     if(x!=y)
     {
      father[x]=y; //链接两个不共根数的数
         sum--;
     }
    }
    int main()
    {
     int m,n;
     while(cin>>m,m)
     {
      int i,a,b;
      cin>>n;
      sum=m-1;
      for(i=1;i<=m;i++)
       father[i]=i;   //初始化
      for(i=1;i<=n;i++)
      {
       cin>>a>>b;
       join(a,b);
      }
      cout<<sum<<endl;
     }
     return 0;
    }

    More is better Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 327680/102400 K (Java/Others) Total Submission(s): 9653    Accepted Submission(s): 3547

    Problem Description Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

    Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

    Input The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)  

    Output The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.

    Sample Input 4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8  

    Sample Output 4 2

    Hint A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect).

    In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.

    #include<stdio.h>
    struct A
    {
     int a;  //记录根数
     int b;  //自己和自己的子数
    }rid[10000005];
    int maxn;
    int find(int x)
    {
     int t=x;
     while(t!=rid[t].a)
      t=rid[t].a;  //追溯其源数
     int i=x;
     while(i!=t)
     {
      int j=rid[i].a;
      rid[i].a=t;  //把所有衍生的数放在源数下
      i=j;
     }
     return t;
    }
    void join(int x,int y)
    {
     int i=find(x),j=find(y);
     if(i!=j)
     {
      rid[j].b=rid[j].b+rid[i].b;  //追寻其源数的子数及其本身的个数
      if(maxn<rid[j].b)
       maxn=rid[j].b; //找最大值
      rid[i].a=j;  //链接两个数~
     }
    }
    int main()
    {
     int n,i,x,y;
     while(~scanf("%d",&n))
     {
      maxn=1;
      for(i=0;i<10000005;i++)
      {
       rid[i].a=i;  //初始化
       rid[i].b=1;
      }
      for(i=0;i<n;i++)
      {
       scanf("%d%d",&x,&y);
       join(x,y);
      }
      printf("%d ",maxn);
     }
     return 0;
    }

    1232卡在find 函数的while 那好久,刚开始用的if,又因为测试数据太简单,所以检查了好久╭(╯^╰)╮

    1856 和1232很像,只要加一个结构体,以及追溯根数的子数和相加~(≧▽≦)/~,但是用C++写居然超!时!了!换C写就没超╮(╯▽╰)╭

  • 相关阅读:
    VS自带的dbghelp.h文件 报错
    Windows 自带的截屏功能
    CentOS 7 安装
    Windows 远程连接 CentOS 7 图形化桌面
    <<、|=、&的小例子
    pip 安装库过慢
    pip -i 和 -U 参数
    windows下安装TA-Lib库
    vector、map 判断某元素是否存在、查找指定元素
    vector push_back报错
  • 原文地址:https://www.cnblogs.com/riddle/p/3196766.html
Copyright © 2011-2022 走看看