zoukankan      html  css  js  c++  java
  • 洛谷 P2936 [USACO09JAN]全流Total Flow

    题目描述

    Farmer John always wants his cows to have enough water and thus has made a map of the N (1 <= N <= 700) water pipes on the farm that connect the well to the barn. He was surprised to find a wild mess of different size pipes connected in an apparently haphazard way. He wants to calculate the flow through the pipes.

    Two pipes connected in a row allow water flow that is the minimum of the values of the two pipe's flow values. The example of a pipe with flow capacity 5 connecting to a pipe of flow capacity 3 can be reduced logically to a single pipe of flow capacity 3:

    +---5---+---3---+ -> +---3---+

    Similarly, pipes in parallel let through water that is the sum of their flow capacities:

    +---5---+

    ---+ +--- -> +---8---+

    +---3---+

    Finally, a pipe that connects to nothing else can be removed; it contributes no flow to the final overall capacity:

    +---5---+

    ---+ -> +---3---+

    +---3---+--

    All the pipes in the many mazes of plumbing can be reduced using these ideas into a single total flow capacity.

    Given a map of the pipes, determine the flow capacity between the well (A) and the barn (Z).

    Consider this example where node names are labeled with letters:

    +-----------6-----------+

    A+---3---+B +Z

    +---3---+---5---+---4---+

    C D

    Pipe BC and CD can be combined:

    +-----------6-----------+

    A+---3---+B +Z

    +-----3-----+-----4-----+

    D Then BD and DZ can be combined:

    +-----------6-----------+

    A+---3---+B +Z

    +-----------3-----------+

    Then two legs of BZ can be combined:

    B A+---3---+---9---+Z

    Then AB and BZ can be combined to yield a net capacity of 3:

    A+---3---+Z

    Write a program to read in a set of pipes described as two endpoints and then calculate the net flow capacity from 'A' to 'Z'. All

    networks in the test data can be reduced using the rules here.

    Pipe i connects two different nodes a_i and b_i (a_i in range

    'A-Za-z'; b_i in range 'A-Za-z') and has flow F_i (1 <= F_i <= 1,000). Note that lower- and upper-case node names are intended to be treated as different.

    The system will provide extra test case feedback for your first 50 submissions.

    约翰总希望他的奶牛有足够的水喝,因此他找来了农场的水管地图,想算算牛棚得到的水的 总流量.农场里一共有N根水管.约翰发现水管网络混乱不堪,他试图对其进行简 化.他简化的方式是这样的:

    两根水管串联,则可以用较小流量的那根水管代替总流量.

    两根水管并联,则可以用流量为两根水管流量和的一根水管代替它们

    当然,如果存在一根水管一端什么也没有连接,可以将它移除.

    请写个程序算出从水井A到牛棚Z的总流量.数据保证所有输入的水管网络都可以用上述方法 简化.

    输入输出格式

    输入格式:

    • Line 1: A single integer: N

    • Lines 2..N + 1: Line i+1 describes pipe i with two letters and an integer, all space-separated: a_i, b_i, and F_i

    输出格式:

    • Line 1: A single integer that the maximum flow from the well ('A') to the barn ('Z')

    输入输出样例

    输入样例#1:
    5 
    A B 3 
    B C 3 
    C D 5 
    D Z 4 
    B Z 6 
    
    输出样例#1:
    3 
    最大流问题
    屠龙宝刀点击就送
    #include <iostream> 
    #include <cstring>
    #include <vector>
    #include <cstdio>
    #include <queue>
    #define inf 0x7ffff
    
    using namespace std;
    
    char a,b;
    bool vis[70];
    int atlas[70][70],Answer,dis[70],n,m,v,i,j;
    bool bfs()
    {
        queue<int>q;
        q.push(0);
        memset(dis,-1,sizeof(dis));
        dis[0]=1;
        while(!q.empty() )
        {
            int f=q.front() ;q.pop() ;
            for(i=0;i<=57;++i)
            {
                if(atlas[f][i]>0&&dis[i]==-1)
                {
                    dis[i]=dis[f]+1;
                    if(i==25) return 1;
                    else q.push(i); 
                }
            }
        }
        return 0;
    }
    void network()
    {
        memset(vis,0,sizeof(vis));vis[0]=1;
        vector<int>vec;
        vec.push_back(0);
        while(!vec.empty() )
        {
            int p=vec.back() ;
            if(p!=25)
            {
                int l;
                for(l=0;l<58;++l)
                {
                    if(atlas[p][l]>0&&!vis[l])
                    {
                        vis[l]=1;
                        vec.push_back(l);
                        break; 
                    }
                }
                if(l>57) vec.pop_back();
            }
            else if(p==25)
            {
                int k,minx=inf;
                for(i=1;i<vec.size() ;++i)
                {
                    int u=vec[i-1],v=vec[i];
                    if(atlas[u][v]>0&&atlas[u][v]<minx)
                    {
                        k=u;
                        minx=atlas[u][v];
                    }
                }
                Answer+=minx;
                for(i=1;i<vec.size() ;++i)
                {
                    int u=vec[i-1],v=vec[i];
                    atlas[u][v]-=minx;
                    atlas[v][u]+=minx;
                }
                while(!vec.empty() &&vec.back() !=k)
                {
                    vis[vec.back() ]=0;
                    vec.pop_back();
                }
            }
        }
    }
    int main()
    {
        scanf("%d",&n);int w;
        for(int i=0;i<n;++i)
        {
            cin>>a>>b>>w;
            atlas[(int)a-65][(int)b-65]+=w;
        }
        while(bfs())
        network();
        printf("%d",Answer);
        return 0;
    }
    
    
    


    我们都在命运之湖上荡舟划桨,波浪起伏着而我们无法逃脱孤航。但是假使我们迷失了方向,波浪将指引我们穿越另一天的曙光。
  • 相关阅读:
    如何把方法(函数)当参数传递
    致加西亚的信 摘录
    算法:C#数组去除重复元素算法研究
    [转帖]SQL SERVER 2005 安全设置
    [转].NET学习网站收集
    C#你真的懂了吗 啥叫引用2
    比IETEST更好用的浏览器兼容性测试软件[绿色]
    [转帖]使用asp.net访问Oracle的方法汇总
    影响力密码 信任你自己
    [转]自动刷新页面的实现方法总结
  • 原文地址:https://www.cnblogs.com/ruojisun/p/6502764.html
Copyright © 2011-2022 走看看