zoukankan      html  css  js  c++  java
  • codevs 1267 老鼠的旅行 2012年CCC加拿大高中生信息学奥赛

    时间限制: 1 s
     空间限制: 128000 KB
     题目等级 : 黄金 Gold
    题目描述 Description

    You are a mouse that lives in a cage in a large laboratory.

    你是一只生活在笼子里的实验室老鼠。

    The laboratory is composed of one rectangular grid of square cages, with a total of R rows and C columns of cages (1 ≤ R,C ≤ 25).

    实验室是一个R行C列的格子矩阵(1 ≤ R,C ≤ 25). 每个格子是一个笼子. (尼玛还要我活么……)

    To get your exercise, the laboratory owners allow you to move between cages.

    为了让你锻炼身体,实验室管理员允许你在笼子之间移动。

    You can move between cages either by moving right between two adjacent cages in the same row, or by moving down between two adjacent cages in the same column.

    你只能向右和向下移动。

    You cannot move diagonally, left or up.

    你不能斜着移动,也不能向上和向左移动。

    Your cage is in one corner of the laboratory, which has the label (1,1) (to indicate top-most row, left-most column).

    你所在的笼子是实验室的左上角,标记为(1,1)

    You would like to visit your brother who lives in the cage labelled (R,C) (bottom-most row, right-most column), which is in the other corner diagonally.

    你想去右下角的笼子(R,C)里找你的女朋友(尼玛老鼠也有女盆友么!!!)

    However, there are some cages which you cannot pass through, since they contain cats.

    但是有一些笼子是不能经过的,因为里面有猫(谁说老鼠怕猫么,还有,管理员有毛病么……)

    Your brother, who loves numbers, would like to know how many different paths there are between your cage and his that do not pass through any cat cage. Write a program to compute this number of cat-free paths.

    你女朋友很爱数学,她想要知道有多少条不同的路径可以从你的笼子到达她的笼子。写一个程序来计算吧。(这样的女朋友不要也罢……)

    输入描述 Input Description

    The first line of input contains two integers R and C, separated by one space representing the number of rows and columns (respectively). On the second line of input is the integer K, the number of cages that contain cats. The next K lines each contain the row and column positions (in that order) for a cage that contains a cat. None of the K cat cages are repeated, and all cages are valid positions. Note also that (1,1) and (R,C) will not be cat cages.

    第一行包含2个整数R和C,第二行一个整数K,代表包含猫的笼子的个数,接下来K行包含K个不同的位置信息,代表K个包含猫的笼子的位置信息,注意(1,1)和(R,C)这两个位置是不会有猫的, 否则出题者就没法活了……

    输出描述 Output Description

    Output the non-negative integer value representing the number of paths between your cage at position (1,1) and your brother’s cage at position (R,C). You can assume the output will be strictly less than 1 000 000 000.

    输出一个非负整数代表你可以去你女朋友笼子里和她啪啪啪的路径数目,你可以假设这个输出会严格小于1,000,000,000。

    样例输入 Sample Input

    样例输入 1:

    2 3

    1

    2 1

    样例输入 2:

    3 4

    3

    2 3

    2 1

    1 4

    样例输出 Sample Output

    样例输出 1: 2

    样例输出 2: 1

    数据范围及提示 Data Size & Hint

     

    棋盘dp

    屠龙宝刀点击就送

    #include <cstring>
    #include <cstdio>
    
    #define max(a,b) a>b?a:b
    using namespace std;
    
    int dp[26][26],tx[26][26];
    int r,c,k;
    int main()
    {
        scanf("%d%d%d",&r,&c,&k);
        dp[1][1]=1;
        for(int x,y;k--;)
        {
            scanf("%d%d",&x,&y);
            tx[x][y]=1;
        }
        for(int i=1;i<=r;i++)
        {
            for(int j=1;j<=c;j++)
            {
                if(i==1&&j!=1) dp[i][j]=dp[i][j-1];
                if(i!=1&&j==1) dp[i][j]=dp[i-1][j];
                if(i>1&&j>1) dp[i][j]=dp[i-1][j]+dp[i][j-1];
                if(tx[i][j]==1) dp[i][j]=0;
            }
        }
        printf("%d",dp[r][c]);
        return 0;
    }
    我们都在命运之湖上荡舟划桨,波浪起伏着而我们无法逃脱孤航。但是假使我们迷失了方向,波浪将指引我们穿越另一天的曙光。
  • 相关阅读:
    2021年中央经济工作会议
    大人物不走直线路径
    批量修改:update inner join导致死锁
    linux 系统centos新添加一个硬盘,分区格式化挂载操作
    vuewaves点击容器出现水波纹效果
    多维表头的DataGridView
    TypeError: Property value expected type of string but got null
    linux下添加简单的开机自启动脚本
    Centos7 自定义 tomcat 的 systemctl 启动脚本
    uniapp的store使用
  • 原文地址:https://www.cnblogs.com/ruojisun/p/6579321.html
Copyright © 2011-2022 走看看