zoukankan      html  css  js  c++  java
  • LUOGU P3112 [USACO14DEC]后卫马克Guard Mark

    题目描述

    Farmer John and his herd are playing frisbee. Bessie throws the

    frisbee down the field, but it’s going straight to Mark the field hand

    on the other team! Mark has height H (1 <= H <= 1,000,000,000), but

    there are N cows on Bessie’s team gathered around Mark (2 <= N <= 20).

    They can only catch the frisbee if they can stack up to be at least as

    high as Mark. Each of the N cows has a height, weight, and strength.

    A cow’s strength indicates the maximum amount of total weight of the

    cows that can be stacked above her.

    Given these constraints, Bessie wants to know if it is possible for

    her team to build a tall enough stack to catch the frisbee, and if so,

    what is the maximum safety factor of such a stack. The safety factor

    of a stack is the amount of weight that can be added to the top of the

    stack without exceeding any cow’s strength.

    FJ将飞盘抛向身高为H(1 <= H <= 1,000,000,000)的Mark,但是Mark

    被N(2 <= N <= 20)头牛包围。牛们可以叠成一个牛塔,如果叠好后的高度大于或者等于Mark的高度,那牛们将抢到飞盘。

    每头牛都一个身高,体重和耐力值三个指标。耐力指的是一头牛最大能承受的叠在他上方的牛的重量和。请计算牛们是否能够抢到飞盘。若是可以,请计算牛塔的最大稳定强度,稳定强度是指,在每头牛的耐力都可以承受的前提下,还能够在牛塔最上方添加的最大重量。

    输入输出格式

    输入格式:
    INPUT: (file guard.in)

    The first line of input contains N and H.

    The next N lines of input each describe a cow, giving its height,

    weight, and strength. All are positive integers at most 1 billion.

    输出格式:
    OUTPUT: (file guard.out)

    If Bessie’s team can build a stack tall enough to catch the frisbee, please output the maximum achievable safety factor for such a stack.

    Otherwise output “Mark is too tall” (without the quotes).

    输入输出样例

    输入样例#1:
    4 10
    9 4 1
    3 3 5
    5 5 10
    4 4 5
    输出样例#1:
    2

    解题思路

    乍一看这道题是个以前讲过的贪心,就是按照力量和重量排序,但是这个还有个高度,并且问的是最大稳定,所以那种方法似乎不行。考虑状压,dp[S]表示选的状态为S时的最大承重,gg[S]表示所选为S时的最大高度,可以提前预处理出来。转移方程dp[S]=max(dp[S],min(dp[S^(1<

    代码

    #include<iostream>
    #include<cstdio>
    #include<cstring>
    
    using namespace std;
    const int MAXN = 21;
    typedef long long LL;
    
    int H,n;
    int dp[1<<MAXN],gg[1<<MAXN];
    int w[MAXN],h[MAXN],a[MAXN];
    int ans=-1;
    
    int main(){
        memset(dp,-0x3f,sizeof(dp));dp[0]=0x3f3f3f3f;
        scanf("%d%d",&n,&H);
        for(register int i=1;i<=n;i++)
            scanf("%d%d%d",&h[i],&w[i],&a[i]);
        for(register int S=0;S<1<<n;S++)
            for(register int i=1;i<=n;i++)
                if(S&(1<<i-1)) gg[S]+=h[i];
        for(register int S=0;S<1<<n;S++){
            for(register int i=1;i<=n;i++)if(((S&(1<<i-1))))
                dp[S]=max(dp[S],min(a[i],dp[S^(1<<i-1)]-w[i]));
            if(gg[S]>=H && dp[S]>=0) ans=max(ans,dp[S]);
        }
        if(ans==-1) puts("Mark is too tall");
        else printf("%d",ans);
        return 0;
    }
  • 相关阅读:
    js一次性删除一个数组中多个元素
    js防抖,节流
    js 生成一个永不重复的ID
    mavon-editor 使用方法以及回显
    导出---后台返回二进制流文件数据,前端转换格式进行下载
    vue 监控enter键触发
    上传视频到阿里云
    前端图片压缩
    向后台传输表情时,手机自带输入法emoji表情的输入,提交及显示——前端解决方案
    vue 之this.$router.push、replace、go的区别
  • 原文地址:https://www.cnblogs.com/sdfzsyq/p/9676911.html
Copyright © 2011-2022 走看看