题目描述
如题,给定N个字符串(第i个字符串长度为Mi,字符串内包含数字、大小写字母,大小写敏感),请求出N个字符串中共有多少个不同的字符串。
输入输出格式
输入格式:
第一行包含一个整数N,为字符串的个数。
接下来N行每行包含一个字符串,为所提供的字符串。
输出格式:
输出包含一行,包含一个整数,为不同的字符串个数。
输入输出样例
输入样例#1: 复制
5
abc
aaaa
abc
abcc
12345
输出样例#1: 复制
4
说明
时空限制:1000ms,128M
数据规模:
对于30%的数据:N<=10,Mi≈6,Mmax<=15;
对于70%的数据:N<=1000,Mi≈100,Mmax<=150
对于100%的数据:N<=10000,Mi≈1000,Mmax<=1500
样例说明:
样例中第一个字符串(abc)和第三个字符串(abc)是一样的,所以所提供字符串的集合为{aaaa,abc,abcc,12345},故共计4个不同的字符串。
题解
hash,据说成完之后加一个素数冲突率更低??
代码
#include<bits/stdc++.h>
#define LL long long
using namespace std;
const int N = 10005;
const int MAXN = 1505;
const int prime = 2333;
const int base = 23;
const int mod = 1e9+7;
char s[MAXN];
int ans;
LL hash[N];
int n;
int main(){
scanf("%d",&n);
for(register int i=1;i<=n;i++){
scanf("%s",s+1);
int len=strlen(s+1);
for(register int j=1;j<=len;j++)
hash[i]=(hash[i]*base+s[j])%mod+prime;
}
sort(hash+1,hash+1+n);
for(register int i=1;i<=n;i++)
if(hash[i]!=hash[i-1]) ans++;
printf("%d",ans);
return 0;
}