zoukankan      html  css  js  c++  java
  • BZOJ 1089 (SCOI 2003) 严格n元树

    Description

      如果一棵树的所有非叶节点都恰好有n个儿子,那么我们称它为严格n元树。如果该树中最底层的节点深度为d
    (根的深度为0),那么我们称它为一棵深度为d的严格n元树。例如,深度为2的严格2元树有三个

      给出n, d,编程数出深度为d的n元树数目。

    Input

      仅包含两个整数n, d( 0 < n < = 32, 0 < = d < = 16)

    Output

      仅包含一个数,即深度为d的n元树的数目。

    Sample Input

    【样例输入1】

    2 2

    【样例输入2】

    2 3

    【样例输入3】

    3 5
    Sample Output

    【样例输出1】

    3

    【样例输出2】

    21

    【样例输出2】

    58871587162270592645034001

    ———————————————————————————-

    题解

    转移方程比较容易思考:
        dp[i]=dp[i-1]^n+1;
    主要考点就是高精的重载运算符。
    

    代码

    #include <iostream>
    #include <string>
    #include <cstring>
    #include <cstdio>
    using namespace std;
    
    const int maxn = 10000;
    
    struct bign{
        int d[maxn], len;
    
        void clean() { while(len > 1 && !d[len-1]) len--; }
    
        bign()          { memset(d, 0, sizeof(d)); len = 1; }
        bign(int num)   { *this = num; } 
        bign(char* num) { *this = num; }
        bign operator = (const char* num){
            memset(d, 0, sizeof(d)); len = strlen(num);
            for(int i = 0; i < len; i++) d[i] = num[len-1-i] - '0';
            clean();
            return *this;
        }
        bign operator = (int num){
            char s[2000]; sprintf(s, "%d", num);
            *this = s;
            return *this;
        }
    
        bign operator + (const bign& b){
            bign c = *this; int i;
            for (i = 0; i < b.len; i++){
                c.d[i] += b.d[i];
                if (c.d[i] > 9) c.d[i]%=10, c.d[i+1]++;
            }
            while (c.d[i] > 9) c.d[i++]%=10, c.d[i]++;
            c.len = max(len, b.len);
            if (c.d[i] && c.len <= i) c.len = i+1;
            return c;
        }
        bign operator - (const bign& b){
            bign c = *this; int i;
            for (i = 0; i < b.len; i++){
                c.d[i] -= b.d[i];
                if (c.d[i] < 0) c.d[i]+=10, c.d[i+1]--;
            }
            while (c.d[i] < 0) c.d[i++]+=10, c.d[i]--;
            c.clean();
            return c;
        }
        bign operator * (const bign& b)const{
            int i, j; bign c; c.len = len + b.len; 
            for(j = 0; j < b.len; j++) for(i = 0; i < len; i++) 
                c.d[i+j] += d[i] * b.d[j];
            for(i = 0; i < c.len-1; i++)
                c.d[i+1] += c.d[i]/10, c.d[i] %= 10;
            c.clean();
            return c;
        }
        bign operator / (const bign& b){
            int i, j;
            bign c = *this, a = 0;
            for (i = len - 1; i >= 0; i--)
            {
                a = a*10 + d[i];
                for (j = 0; j < 10; j++) if (a < b*(j+1)) break;
                c.d[i] = j;
                a = a - b*j;
            }
            c.clean();
            return c;
        }
        bign operator % (const bign& b){
            int i, j;
            bign a = 0;
            for (i = len - 1; i >= 0; i--)
            {
                a = a*10 + d[i];
                for (j = 0; j < 10; j++) if (a < b*(j+1)) break;
                a = a - b*j;
            }
            return a;
        }
        bign operator += (const bign& b){
            *this = *this + b;
            return *this;
        }
    
        bool operator <(const bign& b) const{
            if(len != b.len) return len < b.len;
            for(int i = len-1; i >= 0; i--)
                if(d[i] != b.d[i]) return d[i] < b.d[i];
            return false;
        }
        bool operator >(const bign& b) const{return b < *this;}
        bool operator<=(const bign& b) const{return !(b < *this);}
        bool operator>=(const bign& b) const{return !(*this < b);}
        bool operator!=(const bign& b) const{return b < *this || *this < b;}
        bool operator==(const bign& b) const{return !(b < *this) && !(b > *this);}
    
        string str() const{
            char s[maxn]={};
            for(int i = 0; i < len; i++) s[len-1-i] = d[i]+'0';
            return s;
        }
    };
    
    istream& operator >> (istream& in, bign& x)
    {
        string s;
        in >> s;
        x = s.c_str();
        return in;
    }
    
    ostream& operator << (ostream& out, const bign& x)
    {
        out << x.str();
        return out;
    }
    
    
    bign f[35];
    int n;
    int d;
    
    int main(){
        cin>>n>>d;
        if(n==1&&d==1) return cout<<0,0;
        if(d==0) return cout<<1,0;
        f[1]=1;
        for(int i=1;i<=d;i++) {
            bign tmp=1;
            for(int j=1;j<=n;j++) tmp=tmp*f[i-1];
            f[i]=f[i]+tmp+1;
        }
        bign ans=f[d]-f[d-1];
        cout<<ans;
    }
  • 相关阅读:
    bzoj3160(FFT+回文自动机)
    bzoj2555(后缀自动机+LCT)
    luogu P4299 首都
    Annihilate(SA)
    [FJOI2016]神秘数(脑洞+可持久化)
    [ZJOI2016]大森林(LCT)
    bzoj3756pty的字符串(后缀自动机+计数)
    UVa 11582 Colossal Fibonacci Numbers! (斐波那契循环节 & 快速幂)
    UVa 12563 Jin Ge Jin Qu hao (0-1背包)
    UVa 437 The Tower of Babylon (DAG最长路)
  • 原文地址:https://www.cnblogs.com/sdfzsyq/p/9677089.html
Copyright © 2011-2022 走看看