zoukankan      html  css  js  c++  java
  • ACM——Hero(类似贪心算法)

    Description

    When playing DotA with god-like rivals and pig-like team members, you have to face an embarrassing situation: All your teammates are killed, and you have to fight 1vN.

    There are two key attributes for the heroes in the game, health point (HP) and damage per shot (DPS). Your hero has almost infinite HP, but only 1 DPS.

    To simplify the problem, we assume the game is turn-based, but not real-time. In each round, you can choose one enemy hero to attack, and his HP will decrease by 1. While at the same time, all the lived enemy heroes will attack you, and your HP will decrease by the sum of their DPS. If one hero's HP fall equal to (or below) zero, he will die after this round, and cannot attack you in the following rounds.

    Although your hero is undefeated, you want to choose best strategy to kill all the enemy heroes with minimum HP loss.
     

    Input

    The first line of each test case contains the number of enemy heroes N (1 <= N <= 20). Then N lines followed, each contains two integers DPSi and HPi, which are the DPS and HP for each hero. (1 <= DPSi, HPi <= 1000)
     

    Output

    Output one line for each test, indicates the minimum HP loss.
     

    Sample Input

    1 10 2 2 100 1 1 100
     

    Sample Output

    20 201
     
     
    解释:此题有点像炉石里面的回合制进攻,不过这局先手是对面,所以我方要想要在扣血最少的情况下活下来,就应该把场上DP/HP(或者DP*HP)值最大的先干掉,
    然后在慢慢解决剩下的随从。
     
    #include<stdio.h>
    
    #include<algorithm>
    
    using namespace std;
    
    int n;
    
    struct show
    
    {
        int DP;
        int HP;
        float sum;
    
        show(){};//去掉这个的话下面pro[]会找不到合适的构造函数
    
        show(int i,int a,int b)
        {
            pro[i].DP=a;
            pro[i].HP=b;
            pro[i].sum=a*b;//不可取,因为攻击力是可以取很大的,会超出范围,除非用__int64
        };
    
    }pro[101];
    
    int cmp(show x,show y)
    {
        return x.HP*y.DP<y.HP*x.DP;//如果用除法比,会遇到值相等而无法按照血多少来排名,造成最后结果不是正确的(小了)
    }
    
    
    
    
    
    int main()  
    {  
        int t,i;  
        int sum,ans;  
        while(~scanf("%d",&t))  
        {  
            sum = ans = 0;  
            for(i = 0;i<t;i++)  
            {  
                scanf("%d%d",&pro[i].DP,&pro[i].HP);  
                sum+=pro[i].DP;  
            }  
            sort(pro,pro+t,cmp);  
            for(i = 0;i<t;i++)  
            {  
                ans+=sum*pro[i].HP;  
                sum-=pro[i].DP;  
            }  
            printf("%d\n",ans);  
        }  
    
        return 0;  
    }  
  • 相关阅读:
    navicat设置唯一
    H5图片防盗链处理
    jar包更新
    微信小程序开发工具“当前系统代理不是安全代理”
    Set和Map
    OSS先后上传相同地址的图片
    js遍历删除数组中不符合条件的元素
    SSL配置
    关于socket.io获取客户端真实IP地址
    请在微信客户端打开链接 html
  • 原文地址:https://www.cnblogs.com/shadervio/p/5696957.html
Copyright © 2011-2022 走看看