zoukankan      html  css  js  c++  java
  • 1002 A + B Problem II

    from by HDU oj

    A + B Problem II

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 526070    Accepted Submission(s): 100589


    Problem Description
    I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
     
    Input
    The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
     
    Output
    For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
     
    Sample Input
    2 1 2 112233445566778899 998877665544332211
     
    Sample Output
    Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
     
    AC代码:
    #include<iostream>
    #include<string>
    #include<vector>
    using namespace std;
    int main()
    {
        int i, n, j, k;
        vector<char> a;
        string s1, s2, s;
        while (cin >> n) {
            for (i = 0; i < n; i++) {
                a.clear();
                cin >> s1 >> s2;
                j = (int)s1.size() - 1;
                k = (int)s2.size() - 1;
                while (j >=0 && k >= 0 ) {
                    a.push_back(s1[j] - '0' + s2[k] - '0');
                    j--;
                    k--;
                }
                while (j >= 0) {
                    a.push_back(s1[j] - '0');
                    j--;
                }
                while (k >= 0) {
                    a.push_back(s2[k] - '0');
                    k--;
                }
                for (j = 0; j < (int)a.size() - 1; j++) {
                    if (a[j] >= 10) {
                        a[j+1] += a[j] / 10;
                        a[j] %= 10;
                    }
                }
                if (a[a.size() -1 ] >= 10 ) {
                    int t = a[a.size() - 1] / 10;
                    a[a.size() - 1] = a[a.size() - 1] % 10;
                    a.push_back(t);
                }
                s.clear();
                for (j = (int)a.size() - 1; j >=0 ; j--) {
                    s.push_back(a[j] + '0');
                }
                cout << "Case " << i + 1 << ":" << endl;
                if (i == n - 1) {
                    cout << s1 << " + " << s2 << " = " << s << endl;
                }
                else {
                    cout << s1 << " + " << s2 << " = " << s << endl << endl;
                }
                
            }
        }
        return 0;
    }
  • 相关阅读:
    c++标准库容器【转】
    C++命名空间的解释 【转】
    [转载]定义、公理、定理、推论、命题和引理的区别
    待读论文
    矩阵分解 Matrix Factorization (RegularSVD) 实验总结
    Predicting the Next Location: A Recurrent Model with Spatial and Temporal Contexts AAAI2016
    Discovering Urban Functional Zones Using Latent Activity Trajectories TKDE 2015
    numpy
    python 编程 规范
    深度学习
  • 原文地址:https://www.cnblogs.com/shao-qi/p/13171800.html
Copyright © 2011-2022 走看看