zoukankan      html  css  js  c++  java
  • 20-语言入门-20-Financial Management

     
    描述
    Larry graduated this year and finally has a job. He's making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what's been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.

    输入
    The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.
    输出
    The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output.
    样例输入
    100.00
    489.12
    12454.12
    1234.10
    823.05
    109.20
    5.27
    1542.25
    839.18
    83.99
    1295.01
    1.75
    样例输出
    1581.42
     
     
     
    #include <stdio.h>

    const static int CAL_MONTH_COUNT = 12;

    int main()
    {
       
    float result = 0;
       
    float readLen = CAL_MONTH_COUNT;
       
    while (readLen>0)
        {
           
    float currValue = 0;
           
    scanf("%f",&currValue);
           
    getchar();
           
            result += currValue;
           
            --readLen;
        }
       
       
    printf("%.2f ",result/CAL_MONTH_COUNT);
       
       
    return 0;
    }
     
     
    这段英文大差不差的知道大概是求个平均值,对输出结果提出了要求。
     
  • 相关阅读:
    中文排版CSS心得
    用SHA1或MD5 算法加密数据(示例:对用户身份验证的简单实现)
    Linux 下忘记root密码怎么办
    CSS手册简编
    SC 命令
    DataGrid的数据导入到Excel或CSV
    asp中关于'+'的特殊处理
    卡巴斯基汇总收藏版
    一步一步学习BI(2)Integration Services简单ETL工程
    优化递归的效率zz
  • 原文地址:https://www.cnblogs.com/sharpfeng/p/5141737.html
Copyright © 2011-2022 走看看