zoukankan      html  css  js  c++  java
  • K Face The Right Way题解差分

    题目

    Farmer John has arranged his N (1 ≤ N ≤ 5,000) cows in a row and many of them are facing forward, like good cows. Some of them are facing backward, though, and he needs them all to face forward to make his life perfect.

    Fortunately, FJ recently bought an automatic cow turning machine. Since he purchased the discount model, it must be irrevocably preset to turn K (1 ≤ K ≤ N) cows at once, and it can only turn cows that are all standing next to each other in line. Each time the machine is used, it reverses the facing direction of a contiguous group of K cows in the line (one cannot use it on fewer than K cows, e.g., at the either end of the line of cows). Each cow remains in the same location as before, but ends up facing the opposite direction. A cow that starts out facing forward will be turned backward by the machine and vice-versa.

    Because FJ must pick a single, never-changing value of K, please help him determine the minimum value of K that minimizes the number of operations required by the machine to make all the cows face forward. Also determine M, the minimum number of machine operations required to get all the cows facing forward using that value of K.

    Input

    Line 1: A single integer: N
    Lines 2.. N+1: Line i+1 contains a single character, F or B, indicating whether cow i is facing forward or backward.

    Output

    Line 1: Two space-separated integers: K and M

    Sample Input

    7
    B
    B
    F
    B
    F
    B
    B
    

    Sample Output

    3 3
    

    Hint

    For K = 3, the machine must be operated three times: turn cows (1,2,3), (3,4,5), and finally (5,6,7)

    题解

    思路

    显然同一个区间只会翻转一次,而且当这个区间第一头牛是反的,这个区间就得翻转一次,这样暴力的话是O(n3)的,显然会TLE。
    那就可以用差分来优化,a[i]记录与前一头牛的关系,1表示相同,0表达不同,假定第0头牛是正的。
    差分的话,就是翻转(x, y)时,只对a[x]和a[y+1]取反即可。

    代码

    #include <cstdio>
    using namespace std;
    const int N = 5e3+5;
    int n, m = 9999999, k;
    bool a[N], f[N];
    char c, l = 'F';
    void solve(int x) {
        int s = 0;
        for(int i = 1; i <= n; i++) f[i] = a[i];
        for(int i = 1; i <= n - x + 1; i++) 
            if (!f[i]) f[i] = 1, f[i+x] = !f[i+x], s++;
        for(int i = n - x + 2; i <= n; i++)
            if (!f[i]) return;
        if (m > s) m = s, k = x;
    }
    int main() {
        scanf("%d", &n);
        for(int i = 1; i <= n; i++) {
            scanf(" %c", &c);
            a[i] = (c == l);
            l = c;
        }
        for(int i = 1; i <= n; i++)
            solve(i);
        printf("%d %d\n", k, m);
    }
    
  • 相关阅读:
    我的收藏
    VS2019错误:CS8370 的处理方法
    Win7设置远程访问(免密码)---- Cuba
    【收藏】关于AsposeDLL的使用
    VS Code 离线安装插件(中文包)
    WinCE在启动界面无法进入系统
    WinCE 清除远程连接缓存
    MySQL 创建远程访问用户
    MySQL 命令行(常用)操作数据库
    C# 制作关键字醒目显示控件
  • 原文地址:https://www.cnblogs.com/shawk/p/12659656.html
Copyright © 2011-2022 走看看