zoukankan      html  css  js  c++  java
  • uva11059(最大乘积) 解题心得

    原题:

    Given a sequence of integers S = {S1, S2, . . . , Sn}, you should determine what is the value of the maximum positive product involving consecutive terms of S. If you cannot find a positive sequence, you should consider 0 as the value of the maximum product.

    Input

    Each test case starts with 1 ≤ N ≤ 18, the number of elements in a sequence. Each element Si is an integer such that −10 ≤ Si ≤ 10. Next line will have N integers, representing the value of each element in the sequence. There is a blank line after each test case. The input is terminated by end of file (EOF).

    Output

     For each test case you must print the message: ‘Case #M: The maximum product is P.’, where M is the number of the test case, starting from 1, and P is the value of the maximum product. After each test case you must print a blank line.

    Sample Input

    3 2 4 -3 5 2 5 -1 2 -1

    Sample Output

    Case #1: The maximum product is 8. Case #2: The maximum product is 20.

     分析:直接进行n^2暴力循环就可以比较出最大值了

      注意结果要用long long 并且所有与结果“同级”的也要用long long 

     

    我的代码

    // UVa11059 Maximum Product
    // Rujia Liu
    #include<iostream>
    #include<cstdio>
    using namespace std;
    
    int main() {
        int S[20], kase = 0, n;
        while (cin >> n && n) 
        {
            kase++;
            for (int i = 0; i < n; i++)        cin >> S[i];
            long long ans = 0;
            for (int i = 0; i < n; i++) 
            {
                long long v = 1;
                for (int j = i; j < n; j++) 
                {
                    v *= S[j];
                    if (v > ans) ans = v;
                }
            }
            printf("Case #%d: The maximum product is %lld.
    
    ", kase, ans);
        }
        return 0;
    }
    View Code
  • 相关阅读:
    C++基础之预处理命令
    IOS编程之相机和相册
    NSNotificationCenter通知中心
    UIStoryboard
    IOS文件系统和数据的永久性存储
    IOS实用功能之截图(来自相册和拍照)
    ios学习笔记之block在ios开发中的应用
    [ios]ios-Demo4脱衣服/刮奖app-专业
    制作越狱版本的ipa文件
    IOS之表视图添加搜索栏
  • 原文地址:https://www.cnblogs.com/shawn-ji/p/4696526.html
Copyright © 2011-2022 走看看