zoukankan      html  css  js  c++  java
  • 树状数组 求逆序数 poj 2299

    这里说的很好,把求逆序的步骤说的很明白,我也是看完才懂的,之前自己想了很久就是不明白为什么可以用树状数组求逆序

      

    转载:

    树状数组,具体的说是 离散化+树状数组。这也是学习树状数组的第一题.

    算法的大体流程就是:

    1.先对输入的数组离散化,使得各个元素比较接近,而不是离散的,

    2.接着,运用树状数组的标准操作来累计数组的逆序数。

    算法详细解释:

    1.解释为什么要有离散的这么一个过程?

        刚开始以为999.999.999这么一个数字,对于int存储类型来说是足够了。

        还有只有500000个数字,何必要离散化呢?

        刚开始一直想不通,后来明白了,后面在运用树状数组操作的时候,

        用到的树状数组C[i]是建立在一个有点像位存储的数组的基础之上的,

        不是单纯的建立在输入数组之上。

        比如输入一个9 1 0 5 4,那么C[i]树状数组的建立是在,

        下标 0 1 2 3 4 5 6 7 8 9

        数组 1 1 0 0 1 1 0 0 0 1

        现在由于999999999这个数字相对于500000这个数字来说是很大的,

        所以如果用数组位存储的话,那么需要999999999的空间来存储输入的数据。

        这样是很浪费空间的,题目也是不允许的,所以这里想通过离散化操作,

        使得离散化的结果可以更加的密集。

    2. 怎么对这个输入的数组进行离散操作?

       离散化是一种常用的技巧,有时数据范围太大,可以用来放缩到我们能处理的范围;

       因为其中需排序的数的范围0---999 999 999;显然数组不肯能这么大;

       而N的最大范围是500 000;故给出的数一定可以与1.。。。N建立一个一一映射;

       ①当然用map可以建立,效率可能低点;

       ②这里用一个结构体

       struct Node

       {

          int v,ord;

       }p[510000];和一个数组a[510000];

       其中v就是原输入的值,ord是下标;然后对结构体按v从小到大排序;

       此时,v和结构体的下标就是一个一一对应关系,而且满足原来的大小关系;

       for(i=1;i<=N;i++) a[p[i].ord]=i;

       然后a数组就存储了原来所有的大小信息;

       比如 9 1 0 5 4 ------- 离散后aa数组就是 5 2 1 4 3;

       具体的过程可以自己用笔写写就好了。

    3. 离散之后,怎么使用离散后的结果数组来进行树状数组操作,计算出逆序数?

        如果数据不是很大, 可以一个个插入到树状数组中,

        每插入一个数, 统计比他小的数的个数,

        对应的逆序为 i- getsum( aa[i] ),

        其中 i 为当前已经插入的数的个数,

        getsum( aa[i] )为比 aa[i] 小的数的个数,

        i- sum( aa[i] ) 即比 aa[i] 大的个数, 即逆序的个数

        但如果数据比较大,就必须采用离散化方法

        假设输入的数组是9 1 0 5 4, 离散后的结果aa[] = {5,2,1,4,3};

    在离散结果中间结果的基础上,那么其计算逆序数的过程是这么一个过程。

    1,输入5,   调用upDate(5, 1),把第5位设置为1

    1 2 3 4 5

    0 0 0 0 1

    计算1-5上比5小的数字存在么? 这里用到了树状数组的getSum(5) = 1操作,

    现在用输入的下标1 - getSum(5) = 0 就可以得到对于5的逆序数为0。

    2. 输入2, 调用upDate(2, 1),把第2位设置为1

    1 2 3 4 5

    0 1 0 0 1

    计算1-2上比2小的数字存在么? 这里用到了树状数组的getSum(2) = 1操作,

    现在用输入的下标2 - getSum(2) = 1 就可以得到对于2的逆序数为1。

    3. 输入1, 调用upDate(1, 1),把第1位设置为1

    1 2 3 4 5

    1 1 0 0 1

    计算1-1上比1小的数字存在么? 这里用到了树状数组的getSum(1) = 1操作,

    现在用输入的下标 3 - getSum(1) = 2 就可以得到对于1的逆序数为2。

    4. 输入4, 调用upDate(4, 1),把第5位设置为1

    1 2 3 4 5

    1 1 0 1 1

    计算1-4上比4小的数字存在么? 这里用到了树状数组的getSum(4) = 3操作,

    现在用输入的下标4 - getSum(4) = 1 就可以得到对于4的逆序数为1。

    5. 输入3, 调用upDate(3, 1),把第3位设置为1

    1 2 3 4 5

    1 1 1 1 1

    计算1-3上比3小的数字存在么? 这里用到了树状数组的getSum(3) = 3操作,

    现在用输入的下标5 - getSum(3) = 2 就可以得到对于3的逆序数为2。

    6. 0+1+2+1+2 = 6 这就是最后的逆序数

    分析一下时间复杂度,首先用到快速排序,时间复杂度为O(NlogN),

    后面是循环插入每一个数字,每次插入一个数字,分别调用一次upData()和getSum()

    外循环N, upData()和getSum()时间O(logN) => 时间复杂度还是O(NlogN).

    最后总的还是O(NlogN).


    poj 2299 :

    Ultra-QuickSort
    Time Limit: 7000MS   Memory Limit: 65536K
    Total Submissions: 26864   Accepted: 9642

    Description

    In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 
    9 1 0 5 4 ,

    Ultra-QuickSort produces the output 
    0 1 4 5 9 .

    Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

    Input

    The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

    Output

    For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

    Sample Input

    5
    9
    1
    0
    5
    4
    3
    1
    2
    3
    0
    

    Sample Output

    6
    0
    

    Source

     

    代码:
    #include <iostream>
    #include <stdio.h>
    #include <stdlib.h>
    #include <algorithm>
    #include <string.h>
    using namespace std;
    
    const int maxn=500005;
    int n;
    int aa[maxn]; //离散化后的数组
    int c[maxn];    //树状数组
    
    struct Node{
       int v;
       int order;
    }in[maxn];
    
    int lowbit(int x)
    {
        return x&(-x);
    }
    
    void update(int t,int value)
    {
        int i;
        for(i=t;i<=n;i+=lowbit(i))
        {
            c[i]+=value;
        }
    }
    
    int getsum(int x)
    {
        int i;
        int temp=0;
        for(i=x;i>=1;i-=lowbit(i))
        {
            temp+=c[i];
        }
        return temp;
    }
    
    bool cmp(Node a ,Node b)
    {
        return a.v<b.v;
    }
    
    int main()
    {
        int i,j;
        while(scanf("%d",&n)==1 && n)
        {
            //离散化
            for(i=1;i<=n;i++)
            {
                scanf("%d",&in[i].v);
                in[i].order=i;
            }
            sort(in+1,in+n+1,cmp);
            for(i=1;i<=n;i++) aa[in[i].order]=i;
            //树状数组求逆序
            memset(c,0,sizeof(c));
            long long ans=0;
            for(i=1;i<=n;i++)
            {
                update(aa[i],1);
                ans+=i-getsum(aa[i]);
            }
            cout<<ans<<endl;
        }
        return 0;
    }
    

      

  • 相关阅读:
    大型项目前端架构浅谈
    图标使用新姿势- react 按需引用 svg 的实现
    为什么json 不能使用 int64类型
    SSL证书对SEO网站优有什么影响?使用HTTPS的SEO优势
    web安全测试必须注意的五个方面
    在小程序中实现 Mixins 方案
    网站web前端常见的优化措施
    前端 HTML空格的六种方式
    如何正确选型,React Native 还是 Native?
    CSS3 渐变(Gradients)
  • 原文地址:https://www.cnblogs.com/shenshuyang/p/2591859.html
Copyright © 2011-2022 走看看