zoukankan      html  css  js  c++  java
  • hdu 2844 Coins 多重背包问题

    Coins

    Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
    Total Submission(s) : 5   Accepted Submission(s) : 3

    Font: Times New Roman | Verdana | Georgia

    Font Size:  

    Problem Description

    Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.

    You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.

    Input

    The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.

    Output

    For each test case output the answer on a single line.

    Sample Input

    3 10
    1 2 4 2 1 1
    2 5
    1 4 2 1
    0 0
    

    Sample Output

    8
    4

    对于多重背包问题可以这样解:
     
    MultiplePack(cost,weight,amount)
    {
        if (cost*weight>=V) CompletePack(cost,weight)
        else
        {
            k=1;
            while(k<amount)
            {
                Zero_OnePack(k*cost,k*weight);
                amount-=k;
                k*=2;
            }
            Zero_OnePack(amount*cost,amount*weight)
        }
    }
    

      

    这道题目的cost 和weight 是同一种量.

    #include <iostream>
    #include <stdio.h>
    #include <string.h>
    using namespace std;
    
    int a[105],c[105];
    int dp[100005];
    
    void CompletePack(int cost ,int weight,int n)
    {
    	int i;
    	for(i=cost;i<=n;i++)						//从cost 到n
    		dp[i]=max(dp[i],dp[i-cost]+weight);
    	
    }
    
    void Zero_OnePack(int cost,int weight,int n)
    {
    	int i;
    	for(i=n;i>=cost;i--)					//从n到cost
    		dp[i]=max(dp[i],dp[i-cost]+weight);
    }
    
    int main()
    {
    	int n,m;
    	int i,j,k;
    	while(scanf("%d%d",&n,&m) && n!=0 && m!=0)
    	{
    		for(i=0;i<n;i++)
    			scanf("%d",&a[i]);
    		for(i=0;i<n;i++)
    			scanf("%d",&c[i]);
    		memset(dp,0,sizeof(dp));
    		for(i=0;i<n;i++)
    		{
    			if(a[i]*c[i]>=m) CompletePack(a[i],a[i],m);
    			else
    			{
    				k=1;
    				while(k<c[i])
    				{
    					Zero_OnePack(k*a[i],k*a[i],m);
    					c[i]-=k;
    					k*=2;
    				}
    				Zero_OnePack(c[i]*a[i],c[i]*a[i],m);
    			}
    		}
    		int ans=0;
    		for(i=1;i<=m;i++)
    		{
    			if(dp[i]==i) ans++;
    		}
    		cout<<ans<<endl;
    	}
    	return 0;
    }
    

      

  • 相关阅读:
    parser_url
    fsockopen
    MySql支持的数据类型
    MySql常用字符集
    MySQL各大存储引擎
    MySql数据库基础
    Python 流程控制 超全解析(不可错过)
    python 序列解包(解压缩)
    python常量 (最全常量解析)
    python内存管理(通俗易懂,详细可靠)
  • 原文地址:https://www.cnblogs.com/shenshuyang/p/2644277.html
Copyright © 2011-2022 走看看