zoukankan      html  css  js  c++  java
  • 胜利大逃亡

    Ignatius被魔王抓走了,有一天魔王出差去了,这可是Ignatius逃亡的好机会.

    魔王住在一个城堡里,城堡是一个A*B*C的立方体,可以被表示成A个B*C的矩阵,刚开始Ignatius被关在(0,0,0)的位置,离开城堡的门在(A-1,B-1,C-1)的位置,现在知道魔王将在T分钟后回到城堡,Ignatius每分钟能从一个坐标走到相邻的六个坐标中的其中一个.现在给你城堡的地图,请你计算出Ignatius能否在魔王回来前离开城堡(只要走到出口就算离开城堡,如果走到出口的时候魔王刚好回来也算逃亡成功),如果可以请输出需要多少分钟才能离开,如果不能则输出-1.  

    Input输入数据的第一行是一个正整数K,表明测试数据的数量.每组测试数据的第一行是四个正整数A,B,C和T(1<=A,B,C<=50,1<=T<=1000),它们分别代表城堡的大小和魔王回来的时间.然后是A块输入数据(先是第0块,然后是第1块,第2块......),每块输入数据有B行,每行有C个正整数,代表迷宫的布局,其中0代表路,1代表墙.(如果对输入描述不清楚,可以参考Sample Input中的迷宫描述,它表示的就是上图中的迷宫)

    特别注意:本题的测试数据非常大,请使用scanf输入,我不能保证使用cin能不超时.在本OJ上请使用Visual C++提交.
    Output对于每组测试数据,如果Ignatius能够在魔王回来前离开城堡,那么请输出他最少需要多少分钟,否则输出-1.
    Sample Input

    1
    3 3 4 20
    0 1 1 1
    0 0 1 1
    0 1 1 1
    1 1 1 1
    1 0 0 1
    0 1 1 1
    0 0 0 0
    0 1 1 0
    0 1 1 0

    Sample Output

    11
    可以开三维数组。广度优先搜索
    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <queue>
    using namespace std;
    int dir[6][3]={{0,0,1},{0,0,-1},{1,0,0},{-1,0,0},{0,1,0},{0,-1,0}};
    struct node
    {
        int x,y,z,step;
    }pos,ans;
    int bfs(int A,int B,int C,int T)
    {
        int a[A+3][B+3][C+3],vis[A+3][B+3][C+3],xx,yy,zz;
        memset(vis,0,sizeof(vis));
        queue<node>q;
        pos.x=0;pos.y=0;pos.z=0;pos.step=0;
        q.push(pos);
        vis[0][0][0]=1;
        for(int i=0;i<A;i++)
        {
            for(int j=0;j<B;j++)
            {
                for(int k=0;k<C;k++)
                {
                    scanf("%d",&a[i][j][k]);
                }
            }
        }
        while(!q.empty())
        {
            pos=q.front();
            q.pop();
            if(pos.z==A-1 && pos.x==B-1 && pos.y==C-1) return pos.step;
            for(int row=0;row<6;row++)
            {
                zz=dir[row][0]+pos.z;
                xx=dir[row][1]+pos.x;
                yy=dir[row][2]+pos.y;
                if(zz>=0 && zz<A && xx>=0 && xx<B && yy>=0 && yy<C && vis[zz][xx][yy]==0 && a[zz][xx][yy]==0)
                {
                    ans.x=xx;
                    ans.y=yy;
                    ans.z=zz;
                    ans.step=pos.step+1;
                    if(ans.step>T) return -1;
                    vis[zz][xx][yy]=1;
                    q.push(ans);
                }
            }
        }
        return -1;
    }
    int main()
    {
        int C,A,B,t,T;
        scanf("%d",&t);
        while(t--)
        {
            scanf("%d%d%d%d",&A,&B,&C,&T);
            cout<<bfs(A,B,C,T)<<endl;
        }
        return 0;
    }
  • 相关阅读:
    java开发常见单词(复习整理)
    论文免费查重
    IntelliJ Idea 常用快捷键列表
    Linux命令大全
    Springboot如何上传图片文件
    Springboot JPA如何做条件查询
    Springboot使用单元测试(JUnit Test)
    Springboot使用Mybatis实现完整的增删改查(CRUD)和分页
    Springboot使用JPA实现完整的增删改查(CRUD)和分页
    Springboot-mybatis使用xml方式
  • 原文地址:https://www.cnblogs.com/shinianhuanniyijuhaojiubujian/p/6682636.html
Copyright © 2011-2022 走看看