zoukankan      html  css  js  c++  java
  • HDU 1503 Advanced Fruits

    Advanced Fruits

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 3595    Accepted Submission(s): 1857
    Special Judge


    Problem Description
    The company "21st Century Fruits" has specialized in creating new sorts of fruits by transferring genes from one fruit into the genome of another one. Most times this method doesn't work, but sometimes, in very rare cases, a new fruit emerges that tastes like a mixture between both of them.
    A big topic of discussion inside the company is "How should the new creations be called?" A mixture between an apple and a pear could be called an apple-pear, of course, but this doesn't sound very interesting. The boss finally decides to use the shortest string that contains both names of the original fruits as sub-strings as the new name. For instance, "applear" contains "apple" and "pear" (APPLEar and apPlEAR), and there is no shorter string that has the same property.

    A combination of a cranberry and a boysenberry would therefore be called a "boysecranberry" or a "craboysenberry", for example.

    Your job is to write a program that computes such a shortest name for a combination of two given fruits. Your algorithm should be efficient, otherwise it is unlikely that it will execute in the alloted time for long fruit names.
     
    Input
    Each line of the input contains two strings that represent the names of the fruits that should be combined. All names have a maximum length of 100 and only consist of alphabetic characters.

    Input is terminated by end of file.
     
    Output
    For each test case, output the shortest name of the resulting fruit on one line. If more than one shortest name is possible, any one is acceptable.
     
    Sample Input
    apple peach
    ananas banana
    pear peach
     
    Sample Output
    appleach
    bananas
    pearch
    合并字符串
    #include <iostream>
    #include <algorithm>
    #include <cstring>
    #include <cstdio>
    #include <vector>
    #include <iomanip>
    #include <cmath>
    #include <ctime>
    #include <map>
    #include <set>
    using namespace std;
    #define lowbit(x) (x&(-x))
    #define max(x,y) (x>y?x:y)
    #define min(x,y) (x<y?x:y)
    #define MAX 100000000000000000
    #define MOD 1000000007
    #define pi acos(-1.0)
    #define ei exp(1)
    #define PI 3.141592653589793238462
    #define INF 0x3f3f3f3f3f
    #define mem(a) (memset(a,0,sizeof(a)))
    typedef long long ll;
    int dp[105][105],i,j;
    char a[105],b[105];
    int main()
    {
        while(scanf("%s %s",&a,&b)!=EOF)
        {
            int la=strlen(a);
            int lb=strlen(b);
            memset(dp,0,sizeof(dp));
            for(i=1;i<=la;i++)
            {
                for(j=1;j<=lb;j++)
                {
                    if(a[i-1]==b[j-1]) dp[i][j]=dp[i-1][j-1]+1;
                    else dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
                }
            }
            string s="";
            while(i>0 && j>0)
            {
                if(a[i-1]==b[j-1]) s+=a[i-1],i--,j--;
                else if(dp[i-1][j]>dp[i][j-1]) s+=a[i-1],i--;
                else s+=b[j-1],j--;
            }
            while(i>0) s+=a[i-1],i--;
            while(j>0) s+=b[j-1],j--;
            reverse(s.begin(),s.end());
            cout<<s<<endl;
            memset(a,0,sizeof(a));
            memset(b,0,sizeof(b));
        }
        return 0;
    }
  • 相关阅读:
    OGG-01298 、OGG-00375、OGG-01668 could not find column "TRANSACTION". Error in FILTER clause
    OGG-01519
    oracle RAC 监听状态为"Not All Endpoints Registered"
    ORA-01653: unable to extend table keep.ic_log by 128 in tablespace IDX_LOG
    mysql的binlog太多太大占用大量磁盘空间的解决方法
    启用mysql日志,记录执行过的sql
    定时挂载文件系统步骤
    error c2678 <
    TypeError:'dict' object is not callable
    用SendMessage发WM_COPYDATA消息
  • 原文地址:https://www.cnblogs.com/shinianhuanniyijuhaojiubujian/p/7230885.html
Copyright © 2011-2022 走看看