zoukankan      html  css  js  c++  java
  • POJ 2752 Seek the Name, Seek the Fame

    Seek the Name, Seek the Fame
    Time Limit: 2000MS   Memory Limit: 65536K
    Total Submissions: 20193   Accepted: 10512

    Description

    The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:

    Step1. Connect the father's name and the mother's name, to a new string S.
    Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).

    Example: Father='ala', Mother='la', we have S = 'ala'+'la' = 'alala'. Potential prefix-suffix strings of S are {'a', 'ala', 'alala'}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)

    Input

    The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.

    Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.

    Output

    For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby's name.

    Sample Input

    ababcababababcabab
    aaaaa
    

    Sample Output

    2 4 9 18
    1 2 3 4 5
    KMP next数组的运用
    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <algorithm>
    #include <map>
    #include <set>
    #include <vector>
    #include <queue>
    using namespace std;
    typedef long long ll;
    int nextx[400009],p[400009];
    char a[400009];
    void getnext()
    {
        int i=0,k=-1;
        nextx[0]=-1;
        while(a[i]!='')
        {
            if(k==-1 || a[i]==a[k])
            {
                nextx[++i]=++k;
            }
            else k=nextx[k];
        }
    }
    int main()
    {
        while(scanf("%s",a)!=EOF)
        {
            getnext();
            int len=strlen(a);
            int n=0;
            for(int i=len;nextx[i]!=-1;i=nextx[i])
              p[n++]=i;
            for(int i=n-1;i>=0;i--)
            {
              if(i==n-1) cout<<p[i];
              else cout<<' '<<p[i];
            }
            cout<<endl;
        }
        return 0;
    }
  • 相关阅读:
    UniEAP V4 开发实践说明文档
    SI_WorkShop_V4安装手册
    unieap platform eclipse.ini vm设置
    asp.net 配置 web.config 禁用VS2013自带的Browser Link功能
    unieap 建库
    onserverclick
    工作中记录的命令和知识点(不断更新)
    CentOS 下做端口映射/端口转发
    DELL服务器硬件信息采集SHELL脚本
    Linux中变量#,@,0,1,2,*,$$,$?的意思
  • 原文地址:https://www.cnblogs.com/shinianhuanniyijuhaojiubujian/p/7280868.html
Copyright © 2011-2022 走看看