zoukankan      html  css  js  c++  java
  • hdu1002-A + B Problem II-(java大数)

    A + B Problem II

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 460526    Accepted Submission(s): 89173


    Problem Description
    I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
     
    Input
    The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
     
    Output
    For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
     
    Sample Input
    2 1 2 112233445566778899 998877665544332211
     
    Sample Output
    Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
    import java.math.BigInteger;//操作大型整数
    import java.math.BigDecimal;//操作大型小数
    import java.util.Scanner;
    import java.util.Arrays;
    public class Main//hdu1002
    {
        public static void main(String []args)
        {    
            BigInteger a,b,sum;
            Scanner scan=new Scanner(System.in);
            int t;
            t=scan.nextInt();
            for(int i=1;i<=t;i++)
            {
                a=scan.nextBigInteger();
                b=scan.nextBigInteger();
                sum=a.add(b);
                System.out.println("Case "+i+":");
                System.out.println(a+" + "+b+" = "+sum);
                if(i!=t)
                    System.out.println();    
            }
        }
    }
  • 相关阅读:
    线段树再练习
    SCOI 2014 省选总结
    网络流拓展——最小费用最大流
    【集合!】 20140416 && 20140417集训 总结
    Codeforces Round #215 (Div. 1)
    CDQ分治题目小结
    Codeforces Round #232 (Div. 1)
    Codeforces Round #264 (Div. 2)
    Uva 12361 File Retrieval 后缀数组+并查集
    FFT初步学习小结
  • 原文地址:https://www.cnblogs.com/shoulinniao/p/10391426.html
Copyright © 2011-2022 走看看