zoukankan      html  css  js  c++  java
  • ACM-ICPC 2018 徐州赛区网络预赛 B(dp || 博弈(未完成)

    传送门

    题面:

    In a world where ordinary people cannot reach, a boy named "Koutarou" and a girl named "Sena" are playing a video game. The game system of this video game is quite unique: in the process of playing this game, you need to constantly face the choice, each time you choose the game will provide 1-31−3 options, the player can only choose one of them. Each option has an effect on a "score" parameter in the game. Some options will increase the score, some options will reduce the score, and some options will change the score to a value multiplied by -1−1 .

    That is, if there are three options in a selection, the score will be increased by 11, decreased by 11, or multiplied by -1−1. The score before the selection is 88. Then selecting option 11 will make the score become 99, and selecting option 22 will make the score 77 and select option 33 to make the score -8−8. Note that the score has an upper limit of 100100 and a lower limit of -100−100. If the score is 9999 at this time, an option that makes the score +2+2 is selected. After that, the score will change to 100100 and vice versa .

    After all the choices have been made, the score will affect the ending of the game. If the score is greater than or equal to a certain value kk, it will enter a good ending; if it is less than or equal to a certain value ll, it will enter the bad ending; if both conditions are not satisfied, it will enter the normal ending. Now, Koutarou and Sena want to play the good endings and the bad endings respectively. They refused to give up each other and finally decided to use the "one person to make a choice" way to play the game, Koutarou first choose. Now assume that they all know the initial score, the impact of each option, and the kk, ll values, and decide to choose in the way that works best for them. (That is, they will try their best to play the ending they want. If it's impossible, they would rather normal ending than the ending their rival wants.)

    Koutarou and Sena are playing very happy, but I believe you have seen through the final ending. Now give you the initial score, the kk value, the ll value, and the effect of each option on the score. Can you answer the final ending of the game?

    Input

    The first line contains four integers n,m,k,ln,m,k,l(1le n le 10001≤n≤1000, -100 le m le 100−100≤m≤100 , -100 le l < k le 100−100≤l<k≤100), represents the number of choices, the initial score, the minimum score required to enter a good ending, and the highest score required to enter a bad ending, respectively.

    Each of the next nn lines contains three integers a,b,ca,b,c(age 0a≥0 , bge0b≥0 ,c=0c=0 or c=1c=1),indicates the options that appear in this selection,in which a=0a=0 means there is no option to increase the score in this selection, a>0a>0 means there is an option in this selection to increase the score by aa ; b=0b=0 means there is no option to decrease the score in this selection, b>0b>0 means there is an option in this selection to decrease the score by bb; c=0c=0 means there is no option to multiply the score by -1−1 in this selection , c=1c=1 means there is exactly an option in this selection to multiply the score by -1−1. It is guaranteed that a,b,ca,b,c are not equal to 00 at the same time.

    Output

    One line contains the final ending of the game. If it will enter a good ending,print "Good Ending"(without quotes); if it will enter a bad ending,print "Bad Ending"(without quotes);otherwise print "Normal Ending"(without quotes).

    样例输入1复制

    3 -8 5 -5
    3 1 1
    2 0 1
    0 2 1

    样例输出1复制

    Good Ending

    样例输入2复制

    3 0 10 3
    0 0 1
    0 10 1
    0 2 1

    样例输出2复制

    Bad Ending

    题目来源

    ACM-ICPC 2018 徐州赛区网络预赛

    题意:

        有两个人在玩游戏,他们最开始有积分m分,如果最终的积分val>=k,则进入Bad Ending,如果最终积分val<l 则进入Good Ending。现在一共有n个关卡,每个选项有三个选项a,b,c,a代表使得积分+a,b代表使得积分+b,c==1代表使得积分*-1。如果a或b等于0,则不能选择,题目保证a,b,c不同时为0,A先选,B后选,A想要进入GE,B想要进入BE,他们都会进行最优的操作,问你最后的结局。

     

    分析:一开始就往博弈的方面去考虑的,披着博弈的DP , 没有想到这就是简单的DP转移,a想得到自己想要的结局肯定是越大越好拉 , b想赢肯定是越小越好了,依据这个理论概念,可以dp枚举,怎么DP呢? 设DP(i,j)表示第i个现在分数是J的最小或者最大分数 , 注意范围是-100,100 , 可以偏移也可以用map, 我这是用了map , 防止变量搞错了 ; 

    !!!!!(这题也可以博弈的做法,挡分析挺复杂的,留着以后)

    #include<bits/stdc++.h>
    
    using namespace std ;
    
    const int maxn = 1005;
    map<int , map<int,int> > dp ;
    
    int a[maxn],b[maxn],c[maxn];
    int main( )
    {
        int n , m , k , l;
        scanf("%d%d%d%d" , &n , &m , &k , &l);
        for(int i = 1 ; i<=n ; i++)
        scanf("%d%d%d",&a[i],&b[i],&c[i]);
        for(int i=-100 ; i<=100 ; i++)
        dp[n+1][i] = i;
        for(int i=n ; i>=1 ; i--)
        {
            for(int j=-100 ; j<=100 ; j++)
            {
                if(i%2==0)
                {    dp[i][j]=100;
                    if(a[i])
                    dp[i][j]=min(dp[i][j],dp[i+1][min(j+a[i],100)]);
                    if(b[i])
                    dp[i][j]=min(dp[i][j],dp[i+1][max(j-b[i],-100)]);
                    if(c[i])
                    dp[i][j]=min(dp[i][j],dp[i+1][-j]);
                }
                else{
                    dp[i][j]=-100;
                    if(a[i])
                    dp[i][j]=max(dp[i][j],dp[i+1][min(j+a[i],100)]);
                    if(b[i])
                    dp[i][j]=max(dp[i][j],dp[i+1][max(j-b[i],-100)]);
                    if(c[i])
                    dp[i][j]=max(dp[i][j],dp[i+1][-j]);
                }
            }
        }
        if(dp[1][m]>=k)
        puts("Good Ending");
        else if(dp[1][m]<=l)
        puts("Bad Ending");
        else
        puts("Normal Ending");
    }
    View Code

    总结:以后考虑题的时候,需要多方面的考虑 , 考虑多方法 

  • 相关阅读:
    linux 时间同步
    sublime3 install python3
    Postfix的工作原理
    MySQL启动报错
    Socket server
    自定义静态网卡配置
    Nginx 404 500
    Pymysql
    Gitlab smtp 设置
    Windows 文件自动同步共享工具
  • 原文地址:https://www.cnblogs.com/shuaihui520/p/9623520.html
Copyright © 2011-2022 走看看