hdu1247
Hat’s Words
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 20276 Accepted Submission(s): 7108
Problem Description
A hat’s word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.
You are to find all the hat’s words in a dictionary.
Input
Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 50,000 words.
Only one case.
Output
Your output should contain all the hat’s words, one per line, in alphabetical order.
Sample Input
a
ahat
hat
hatword
hziee
word
Sample Output
ahat
hatword
Author
戴帽子的
代码
#include <iostream>
#include <cstdio>
#include <string>
#include <cstring>
#include <cmath>
#include <sstream>
#include <algorithm>
#include <set>
#include <map>
#include <vector>
#include <queue>
#include <iomanip>
#include <stack>
using namespace std;
typedef long long LL;
const int INF = 0x3f3f3f3f;
const int N = 5e4 + 5;
const int MOD = 1e9 + 9;
#define lson l, m, rt << 14
#define rson m + 1, r, rt << 1 | 1
#define F(i, l, r) for(int i = l;i <= (r);++i)
#define RF(i, l, r) for(int i = l;i >= (r);--i)
vector<string> v;
map<string, int> m;
int main()
{
//freopen("in.txt", "r", stdin);
string s;
while(cin >> s) {v.push_back(s);m[s]++;}
int len = v.size();
F(i, 0, len - 1)
{
int t = v[i].size();
F(j, 1, t - 2)
if(m[v[i].substr(j)] && m[v[i].substr(0, j)])
{cout << v[i] << endl;break;}
}
return 0;
}