zoukankan      html  css  js  c++  java
  • HDU 1018 Big Number

    注册了HDU的账号以后从1001开始按顺序可以做的就做下去,先上题目:

    Big Number

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 18921    Accepted Submission(s): 8458


    Problem Description
    In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
     

     

    Input
    Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.
     

     

    Output
    The output contains the number of digits in the factorial of the integers appearing in the input.
     

     

    Sample Input
    2 10 20
     

     

    Sample Output
    7 19
     
     
      这一题题意就是求某个数n的阶乘有多少位。一开始没有头绪,后来来了人家的题解,人家给出了2种方法。一种是用公式(斯特林公式),另一种是常规方法。对这种方法的理解就是一个数A(j位)和另一个数B(k位)相乘,得到的数的位数是j+k-1位(这里之前的经验认为可能是j+k-1或者是j+k位,但是想了一下发现只会是j+k-1位,因为9*9==81,就算是进位加1也最高位也不会大于9),所以这里只需要求出A,B的位数就可以得到积的位数。这里使用了log10()函数,这函数的输入需要强制转换为浮点,而且输出也是double,但一开始相加的时候不需要管,只是最后输出的时候要强制装换为int再加上1。
     
    上代码:
      
    #include <iostream>
    #include <stdio.h>
    #include <math.h>
    using namespace std;
    
    int main()
    {
        int n;
        scanf("%d",&n);
        while(n--)
        {
            int t,i;
            double sum=0;
            scanf("%d",&t);
            for(i=1;i<=t;i++)
            {
                sum+=log10((double)i);
            }
            printf("%d\n",(int)sum+1);
        }
        return 0;
    }
  • 相关阅读:
    Smobiler实现手机弹窗
    在 ASP.NET Web API 中使用 Attribute 统一处理异常
    VMWare的网络模式说明
    Windows Server2008 IIS通过Nginx实现绑定多个https域名
    Error while Launching activity
    Android 动态渐变按钮
    mysql安装和配置详解以及Navicat连接失败问题
    selenium的基础学习
    使用Pandas.read_csv时出现OSError: Initializing from file failed
    sklearn 机器学习 Pipeline 模板
  • 原文地址:https://www.cnblogs.com/sineatos/p/2990324.html
Copyright © 2011-2022 走看看