zoukankan      html  css  js  c++  java
  • [结题报告]100 The 3n + 1 problem Time limit: 3.000 seconds

     The 3n + 1 problem 

    Background

    Problems in Computer Science are often classified as belonging to a certain class of problems (e.g., NP, Unsolvable, Recursive). In this problem you will be analyzing a property of an algorithm whose classification is not known for all possible inputs.

    The Problem

    Consider the following algorithm:

     
    		1. 		 input n

    2. print n

    3. if n = 1 then STOP

    4. if n is odd then tex2html_wrap_inline44

    5. else tex2html_wrap_inline46

    6. GOTO 2

    Given the input 22, the following sequence of numbers will be printed 22 11 34 17 52 26 13 40 20 10 5 16 8 4 2 1

    It is conjectured that the algorithm above will terminate (when a 1 is printed) for any integral input value. Despite the simplicity of the algorithm, it is unknown whether this conjecture is true. It has been verified, however, for all integers n such that 0 < n < 1,000,000 (and, in fact, for many more numbers than this.)

    Given an input n, it is possible to determine the number of numbers printed (including the 1). For a given nthis is called the cycle-length of n. In the example above, the cycle length of 22 is 16.

    For any two numbers i and j you are to determine the maximum cycle length over all numbers between i and j.

    The Input

    The input will consist of a series of pairs of integers i and j, one pair of integers per line. All integers will be less than 1,000,000 and greater than 0.

    You should process all pairs of integers and for each pair determine the maximum cycle length over all integers between and including i and j.

    You can assume that no operation overflows a 32-bit integer.

    The Output

    For each pair of input integers i and j you should output ij, and the maximum cycle length for integers between and including i and j. These three numbers should be separated by at least one space with all three numbers on one line and with one line of output for each line of input. The integers i and j must appear in the output in the same order in which they appeared in the input and should be followed by the maximum cycle length (on the same line).

    Sample Input

    1 10
    100 200
    201 210
    900 1000
    

    Sample Output

    1 10 20
    100 200 125
    201 210 89
    900 1000 174


    代码参考:

    本题大意是通过其6步骤,不断重复循环计算,直至n=1时,计算结束,得到周期。值得一题的是,输入10 1 和 1 10 要作区别。

    #include"stdio.h"
    int fun(int n) //自定义函数 ; 
    { int s=0,flag=1;
    while(flag) //循环算出周期T; 
    {if(n%2==0) 
    {s++;n/=2;}
    else
    if(n==1)
    {s++;flag=0;}
    else
    {s++;n=3*n+1;} 
    }
    return s;
    } 
    main()
    { int i,j,t,max,p,m,n; //定义变量; 
    while(scanf("%d%d",&i,&j)!=EOF) //输入数字范围 ; 
    { m=i;
    n=j; //将变量另外保存; 
    if(i>j) //防止系统使诈,保证前小后大; 
    {p=i;
    i=j;
    j=p;
    }
    max=fun(i); //调用函数,确定max值; 
    i++;
    for( ;i<=j;i++) //循环算出在此区间内的所有数字的周期 
    {t=fun(i);
    if(t>max) //比较得出最大的周期 
    max=t;}
    printf("%d %d %d\n",m,n,max); //输出 
    } 
    return 0;
    }
  • 相关阅读:
    checkbox美化
    JS 之简单计算器
    python实现简单用户认证和角色制授权
    搭建高性能web服务
    纯JS实现fadeIn 和fadeOut
    纯CSS实现气泡框
    javascript之对象(二)&& 继承问题
    JavaScript之对象(一)
    Web发展史
    [LeetCode 256] Paint House
  • 原文地址:https://www.cnblogs.com/sjy123/p/2878847.html
Copyright © 2011-2022 走看看