zoukankan      html  css  js  c++  java
  • [结题报告]11364 Parking Time limit: 1.000 seconds


      C: Optimal Parking 

    When shopping on Long Street, Michael usually parks his car at some random location, and then walks to the stores he needs. Can you help Michael choose a place to park which minimises the distance he needs to walk on his shopping round?

    \epsfbox{p11364.eps}<tex2html_verbatim_mark>

    Long Street is a straight line, where all positions are integer. You pay for parking in a specific slot, which is an integer position on Long Street. Michael does not want to pay for more than one parking though. He is very strong, and does not mind carrying all the bags around.

    Input 

    The first line of input gives the number of test cases, 1$ \le$t$ \le$100 <tex2html_verbatim_mark>. There are two lines for each test case. The first gives the number of stores Michael wants to visit, 1$ \le$n$ \le$20 <tex2html_verbatim_mark>, and the second gives their n <tex2html_verbatim_mark>integer positions on Long Street, 0$ \le$xi$ \le$99 <tex2html_verbatim_mark>.

    Output 

    Output for each test case a line with the minimal distance Michael must walk given optimal parking.

    Sample Input 

    2 
    4 
    24 13 89 37 
    6 
    7 30 41 14 39 42
    

    Sample Output 

    152
    70
    

     参考代码:

    题目大意讲一个人车停在什么地方去逛街的路程最短,其实在店按高低排好,其路程都是(最大路程-最小路程)*2。首先,冒泡讲若干数进行排序,排序完成后,第一个数和最后一个数分别代表最大数和最小数,(当然,如果觉得排序麻烦,也可以先定义个min,max,然后各个数进行比较求出最大和最小).然后就可以求出这个人要走的路程了.

    #include"stdio.h"
    int main(void)
    {
        int t,n,i,j,swap,temp;
        int a[20];
        scanf("%d",&t);
        while(t--)
        {
            scanf("%d",&n);
            for(i=0;i<n;i++)
            scanf("%d",&a[i]);
            for(i=0;i<n-1;i++)           //冒泡排序       
            {
                swap=0;
                for(j=0;j<n-i-1;j++)         
                if(a[j]<a[j+1])
                {
                    swap=1;
                    temp=a[j+1];
                    a[j+1]=a[j];
                    a[j]=temp;
                }
                if(!swap)break;
               }
            printf("%d\n",(a[0]-a[n-1])*2);
    
        }
        return 0;
    }
  • 相关阅读:
    <C++ QT4 GUI 编程>第一章笔记
    生成snmp++动态库
    PHP 5.3 新特性
    编译安装-Subversion 1.8.5
    Xen入门系列四【Xen 管理实操】
    Xen入门系列三【Xen 管理工具 xm】
    COMET探索系列三【异步通知服务器关闭数据连接实现思路】
    PHP生成二维码【谷歌API+qrcode+圆角Logo】
    SSH免密码登陆详解
    COMET探索系列二【Ajax轮询复用模型】
  • 原文地址:https://www.cnblogs.com/sjy123/p/2923601.html
Copyright © 2011-2022 走看看