zoukankan      html  css  js  c++  java
  • Out of Hay(poj2395)(并查集)

    Out of Hay
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 11580   Accepted: 4515

    Description

    The cows have run out of hay, a horrible event that must be remedied immediately. Bessie intends to visit the other farms to survey their hay situation. There are N (2 <= N <= 2,000) farms (numbered 1..N); Bessie starts at Farm 1. She'll traverse some or all of the M (1 <= M <= 10,000) two-way roads whose length does not exceed 1,000,000,000 that connect the farms. Some farms may be multiply connected with different length roads. All farms are connected one way or another to Farm 1. 

    Bessie is trying to decide how large a waterskin she will need. She knows that she needs one ounce of water for each unit of length of a road. Since she can get more water at each farm, she's only concerned about the length of the longest road. Of course, she plans her route between farms such that she minimizes the amount of water she must carry. 

    Help Bessie know the largest amount of water she will ever have to carry: what is the length of longest road she'll have to travel between any two farms, presuming she chooses routes that minimize that number? This means, of course, that she might backtrack over a road in order to minimize the length of the longest road she'll have to traverse.

    Input

    * Line 1: Two space-separated integers, N and M. 

    * Lines 2..1+M: Line i+1 contains three space-separated integers, A_i, B_i, and L_i, describing a road from A_i to B_i of length L_i.

    Output

    * Line 1: A single integer that is the length of the longest road required to be traversed.

    Sample Input

    3 3
    1 2 23
    2 3 1000
    1 3 43

    Sample Output

    43

    Hint

    OUTPUT DETAILS: 

    In order to reach farm 2, Bessie travels along a road of length 23. To reach farm 3, Bessie travels along a road of length 43. With capacity 43, she can travel along these roads provided that she refills her tank to maximum capacity before she starts down a road.

    Source

    /*求最小生成树中最大的权值*/
    #include<stdio.h>
    #include<algorithm>
    using namespace std;
    int pre[2020];
    int ans;
    struct st
    {
    	int a,b,l;
    }data[10010];
    int find(int N)
    {
    	return pre[N]==N?N:pre[N]=find(pre[N]);
    } 
    int cmp(st a,st b)
    {
    	return a.l<b.l;
    }
    int main()
    {      
        int i,n,m,ans,x,y;
    	scanf("%d %d",&n,&m);
    	for(i=1;i<=n;i++)
    	pre[i]=i;
    	for(i=1;i<=m;i++)
    	scanf("%d%d%d",&data[i].a,&data[i].b,&data[i].l);
    	sort(data+1,data+m+1,cmp);
    	for(i=1,ans=0;i<=m;i++)
    	{
    		x=find(data[i].a);//常常写成x=pre[data[i].a]!!!理解最重要!

    ! y=find(data[i].b); if(x!=y) { if(x>y) pre[x]=y; else pre[y]=x; ans=max(ans,data[i].l); } } printf("%d ",ans); return 0; }



  • 相关阅读:
    1.第一个java程序
    5.第三章 运算符和基本选择结构
    7.关系运算符
    4.第二章章末总结
    3.计算员工工资
    JAVA并发操作——Thread常见用法(Sleep,yield,后台线程)
    JAVA 对象序列化(一)——Serializable
    JAVA 线程中的异常捕获
    JAVA反射机制实例
    JAVA 对象序列化(二)——Externalizable
  • 原文地址:https://www.cnblogs.com/slgkaifa/p/6756691.html
Copyright © 2011-2022 走看看