zoukankan      html  css  js  c++  java
  • Hie with the Pie POJ

     Hie with the Pie POJ - 3311 

    The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you to write a program to help him.

    Input

    Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n). The jth value on the ith line indicates the time to go directly from location i to location j without visiting any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from location i to j may not be the same as the time to go directly from location j to i. An input value of n = 0 will terminate input.

    Output

    For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

    Sample Input

    3
    0 1 10 10
    1 0 1 2
    10 1 0 10
    10 2 10 0
    0

    Sample Output

    8


    题意:一个快递员送n个物品,给出i地点到j地点的长度,送完所有的后返回起始点0,问最短可以跑多少
    思路:n最大为10,先跑一遍floyd,之后直接全排列所有的情况,一开始没有初始化minnWA了。。。
    #include<cstdio>
    #include<iostream>
    #include<algorithm>
    #include<cstring>
    #include<sstream>
    #include<cmath>
    #include<stack>
    #include<cstdlib>
    #include <vector>
    #include<queue>
    using namespace std;
    
    #define ll long long
    #define llu unsigned long long
    #define INF 0x3f3f3f3f
    #define PI acos(-1.0)
    const int maxn =  1e5+5;
    const ll mod = 1e9+7;
    
    int n;
    ll cost[15][15];
    int arr[15];
    void swap(int x,int y)
    {
        int temp=arr[x];
        arr[x]=arr[y];
        arr[y]=temp;
    }
    ll minn=INF;
    int resove(int x)//递归函数
    {
        if(x==n)//当尝试对不存在的数组元素进行递归时,标明所有数已经排列完成,输出。
        {
            ll ans=0;
            for(int i=0;i<n-1;i++)
            {
                //printf("%d->%d ",arr[i]+1,arr[i+1]+1);
                ans += cost[arr[i]+1][arr[i+1]+1];
            }
            //cout<<arr[0]+1 << " "<<arr[n-1]+1;
            //cout<<endl;
            ans = ans + cost[0][arr[0]+1] + cost[arr[n-1]+1][0];
    
            minn = min(minn,ans);
           // cout<<minn<<endl;
            return 0;
        }
        for(int i=x;i<n;i++)
        {
            swap(x,i);
            resove(x+1);
            swap(x,i);
        }
    
    }
    //int main()
    //{
    //    for(int i=0;i<=12;i++)
    //        arr[i] = i;
    //    n=4;
    //    resove(0);
    //}
    
    void floyd()
    {
        for(int k=0;k<=n;k++)
            for(int i=0;i<=n;i++)
                for(int j=0;j<=n;j++)
                  cost[i][j] = min(cost[i][j],cost[i][k] + cost[k][j]);
    }
    int main()
    {
    
        while(scanf("%d",&n) && n)
        {
    
            minn = INF;
    //        for(int i=0;i<=15;i++)
    //            for(int j=0;j<=15;j++)
    //                cost[i][j]=INF;
            for(int i=0;i<=n;i++)
            {
                for(int j=0;j<=n;j++)
                {
                    scanf("%lld",&cost[i][j]);
                }
            }
            floyd();
            for(int i=0;i<=14;i++)
                arr[i] = i;
    
            resove(0);
            cout<<minn<<endl;
        }
    }
    /*
    Sample Input
    3
    0 1 10 10
    1 0 1 2
    10 1 0 10
    10 2 10 0
    0
    Sample Output
    8
     */
    View Code


  • 相关阅读:
    软件测试的定义及分类总结
    Selenium下拉菜单(Select)的操作Selenium快速入门(五)
    Selenium框架切换Selenium快速入门(七)
    元素(WebElement)Selenium快速入门(三)
    Selenium窗口切换Selenium快速入门(六)
    Selenium简介与环境搭配Selenium快速入门(一)
    测试用例的几种常见设计方法
    driver.get()和driver.navigate().to()到底有什么不同?Selenium快速入门(四)
    元素定位Selenium快速入门(二)
    关于VS2010与SQL Server2008 R2的安装问题
  • 原文地址:https://www.cnblogs.com/smallhester/p/10290462.html
Copyright © 2011-2022 走看看