zoukankan      html  css  js  c++  java
  • AreYouBusy HDU

    AreYouBusy

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
    Total Submission(s): 5176    Accepted Submission(s): 2069


    Problem Description
    Happy New Term!
    As having become a junior, xiaoA recognizes that there is not much time for her to AC problems, because there are some other things for her to do, which makes her nearly mad.
    What's more, her boss tells her that for some sets of duties, she must choose at least one job to do, but for some sets of things, she can only choose at most one to do, which is meaningless to the boss. And for others, she can do of her will. We just define the things that she can choose as "jobs". A job takes time , and gives xiaoA some points of happiness (which means that she is always willing to do the jobs).So can you choose the best sets of them to give her the maximum points of happiness and also to be a good junior(which means that she should follow the boss's advice)?
     
    Input
    There are several test cases, each test case begins with two integers n and T (0<=n,T<=100) , n sets of jobs for you to choose and T minutes for her to do them. Follows are n sets of description, each of which starts with two integers m and s (0<m<=100), there are m jobs in this set , and the set type is s, (0 stands for the sets that should choose at least 1 job to do, 1 for the sets that should choose at most 1 , and 2 for the one you can choose freely).then m pairs of integers ci,gi follows (0<=ci,gi<=100), means the ith job cost ci minutes to finish and gi points of happiness can be gained by finishing it. One job can be done only once.
     
    Output
    One line for each test case contains the maximum points of happiness we can choose from all jobs .if she can’t finish what her boss want, just output -1 .
     
     
     Sample Input
    3 3
    2 1
    2 5
    3 8
    2 0
    1 0
    2 1
    3 2
    4 3
    2 1
    1 1
    
    3 4
    2 1
    2 5
    3 8
    2 0
    1 1
    2 8
    3 2
    4 4
    2 1
    1 1
    
    1 1
    1 0
    2 1
    
    5 3
    2 0
    1 0
    2 1
    2 0
    2 2
    1 1
    2 0
    3 2
    2 1
    2 1
    1 5
    2 8
    3 2
    3 8
    4 9
    5 10
    Sample Output
    5
    13
    -1
    -1

    题意 :三类型工作,至多做一件至少做一件和随意做,问value的最大值

    思路:多组背包,分类讨论

    #include<iostream>
    #include<cstdio>
    #include<algorithm>
    #include<cstring>
    #include<sstream>
    #include<cmath>
    #include<cstdlib>
    #include<queue>
    #include<map>
    #include<set>
    #include<vector>
    using namespace std;
    #define INF 0x3f3f3f3f
    const  int maxn=15;
    const double eps=1e-10;
    int c[105],g[105];
    int dp[105][105];
    int main()
    {
        int n,T,m,s,i,j,k;
        while(~scanf("%d %d",&n,&T))
        {
            memset(dp,-1,sizeof(dp));
            memset(dp[0],0,sizeof(dp[0]));
            for(i=1;i<=n;i++)
            {
                scanf("%d %d",&m,&s);
                for(j=0;j<m;j++)
                    scanf("%d%d",&c[j],&g[j]);
                if(s==0)
                {
                    for(k=0;k<m;k++)
                        for(j=T;j>=c[k];j--)
                        {
                            if(dp[i][j-c[k]]!=-1)
                                dp[i][j]=max(dp[i][j],dp[i][j-c[k]]+g[k]);
                            if(dp[i-1][j-c[k]]!=-1)
                                dp[i][j]=max(dp[i][j],dp[i-1][j-c[k]]+g[k]);
                        }
                }
                else if(s==1)
                {
                    for(j=0;j<=T;j++)
                        dp[i][j]=dp[i-1][j];
                    for(k=0;k<m;k++)
                        for(j=T;j>=c[k];j--)
                            if(dp[i-1][j-c[k]]!=-1)
                                dp[i][j]=max(dp[i][j],dp[i-1][j-c[k]]+g[k]);
                }
                else
                {
                    for(j=0;j<=T;j++)
                        dp[i][j]=dp[i-1][j];
                    for(k=0;k<m;k++)
                        for(j=T;j>=c[k];j--)
                            if(dp[i][j-c[k]]!=-1)
                                dp[i][j]=max(dp[i][j],dp[i][j-c[k]]+g[k]);
                }
            }
            cout<<dp[n][T]<<endl;
        }
        return 0;
    }
  • 相关阅读:
    windows 安装mysql 步骤
    x-editable 的使用方法
    asp.net连接数据库
    fedora下根据字符查找软件包
    ubuntu 常用命令
    第8课-库函数方式文件编程
    第7课-系统调用方式文件编程
    第6课-函数库设计
    第5课-Linux编程规范
    第4课-Linux应用程序地址布局
  • 原文地址:https://www.cnblogs.com/smallhester/p/9500318.html
Copyright © 2011-2022 走看看