zoukankan      html  css  js  c++  java
  • poj 3684 Physics Experiment 弹性碰撞

    Physics Experiment
    Time Limit: 1000MS   Memory Limit: 65536K
    Total Submissions: 1489   Accepted: 509   Special Judge

    Description

    Simon is doing a physics experiment with N identical balls with the same radius of R centimeters. Before the experiment, all N balls are fastened within a vertical tube one by one and the lowest point of the lowest ball is H meters above the ground. At beginning of the experiment, (at second 0), the first ball is released and falls down due to the gravity. After that, the balls are released one by one in every second until all balls have been released. When a ball hits the ground, it will bounce back with the same speed as it hits the ground. When two balls hit each other, they with exchange their velocities (both speed and direction).

    Simon wants to know where are the N balls after T seconds. Can you help him?

    In this problem, you can assume that the gravity is constant: g = 10 m/s2.

    Input

    The first line of the input contains one integer C (C ≤ 20) indicating the number of test cases. Each of the following lines contains four integers NHRT.
    1≤ N ≤ 100.
    1≤ H ≤ 10000
    1≤ R ≤ 100
    1≤ T ≤ 10000

    Output

    For each test case, your program should output N real numbers indicating the height in meters of the lowest point of each ball separated by a single space in a single line. Each number should be rounded to 2 digit after the decimal point.

    Sample Input

    2
    1 10 10 100
    2 10 10 100

    Sample Output

    4.95
    4.95 10.20

    Source

     
    题意:有n个小球从一管道开始下落,每秒钟下落一个,已知管口离地面的距离h及小球半径r,所有的碰撞均是弹性碰撞,求ts时,各个小球的位置;
     
    分析:这道题很类似挑战上的一道蚂蚁的题目,那道题目核心的思想就是,蚂蚁碰撞后掉头的效果与碰到后直接“穿过”效果是一样的;不过那道题目蚂蚁没有半径,这道题目不一样的地方就是小球是有半径的,怎么处理呢?
     
    分三个过程来看吧:1,假所有的小球都是没有半径的,且从同一高度每隔1s掉下,,很显然,这个时候求t时的小球的位置,只要求出单独的小球位置,然后再sort排个序就好,(sort排序是因为小球相对位置不变,即刚释放时最下边的小球不管怎么跳还是在最下面),这个时候跟蚂蚁是几乎差不多的,碰了等于没碰。
    2.假设两个小球是有半径的,且是紧挨着每隔1s落下,这时候,因为小球有半径,其实碰了还是等于没碰,比如,假设如下图所示
    a,b两球碰撞时,由速度交换可知,可以当做a向上瞬移2*r,且保持原来的速度,b向下瞬移2*r,且可保持原来的速度,那么a能够达到的最大高度变成了原来的b的初始位置(假设b原来放在a的上方),b能够达到的最大高度就变成了a(因为瞬移的结果是增大了a的2*h的势能,削弱了b的2*h的势能),最终的结果是a变成了原来的b球,B变成了原来的a球,总的效果其实就是没有碰撞,多个球的于此类似。其实核心思想是,每次碰撞时,a球起初(刚释放时)势能要比b球少2*r(因为相对顺序不变),而碰撞后的瞬移使得a球增加了2*r的势能,b球减少了2*r的势能,因此最后变成了a比b还多了2*r的势能,也就是a,b的互换了。
    3.其实这样做的出来了,不过为了计算简便,可以再来一个简化,假设两个球紧挨着同一时刻一起下落会怎样?显然,在上面的球高度始终要比下面的球高2×r,因此计算上可以就计算下面的一个球,其他球累加2*r就好
    #include<cstdio>
    #include <iostream>
    #include <cstdio>
    #include <cstring>
    #include <cstdlib>
    #include <cmath>
    #include <vector>
    #include <queue>
    #include<map>
    #include <algorithm>
    #include <set>
    using namespace std;
    #define MM(a) memset(a,0,sizeof(a))
    typedef long long LL;
    typedef unsigned long long ULL;
    const int mod = 1000000007;
    const double eps = 1e-10;
    const int inf = 0x3f3f3f3f;
    const double g=10;
    int cas,n,h,r,t,k;
    double t0,tx,a[105],temp;
    double solve(int x)
    {
         if(x<0) return h;
         t0=sqrt(2*h*1.0/g);
         k=int(x/t0);
         if(k%2==0)  temp=x-k*t0;
         else    temp=t0-(x-k*t0);
         return h-0.5*g*temp*temp;
    }
    int main()
    {
        cin>>cas;
        while(cas--)
        {
            scanf("%d %d %d %d",&n,&h,&r,&t);
            for(int i=1;i<=n;i++)
               a[i]=solve(t-(i-1));
            sort(a+1,a+n+1);
            for(int i=1;i<=n;i++)
                printf("%.2f%c",a[i]+2*(i-1)*r/100.0,i==n?'
    ':' ');//注意%s输出字符串,%c输出字符,所以这个地方不能用“”
        }  //因为%c无法输出“”字符串
        return 0;
    }
  • 相关阅读:
    Python实现DES加密算法
    空循环,g++ O2优化
    java 高并发下超购问题解决
    原型模式
    Lambda速学
    观察者模式
    略读策略模式
    .net 字典的速学
    执行计划准备篇
    关于“策略模式”与“桥接模式”的问题
  • 原文地址:https://www.cnblogs.com/smilesundream/p/5134406.html
Copyright © 2011-2022 走看看