zoukankan      html  css  js  c++  java
  • hdu 1297

    Children’s Queue

    Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 959 Accepted Submission(s): 534

    Problem Description
    There are many students in PHT School. One day, the headmaster whose name is PigHeader wanted all students stand in a line. He prescribed that girl can not be in single. In other words, either no girl in the queue or more than one girl stands side by side. The case n=4 (n is the number of children) is like
    FFFF, FFFM, MFFF, FFMM, MFFM, MMFF, MMMM
    Here F stands for a girl and M stands for a boy. The total number of queue satisfied the headmaster’s needs is 7. Can you make a program to find the total number of queue with n children?
     

    Input
    There are multiple cases in this problem and ended by the EOF. In each case, there is only one integer n means the number of children (1<=n<=1000)
     

    Output
    For each test case, there is only one integer means the number of queue satisfied the headmaster’s needs.
     

    Sample Input
    1
    2
    3
     

    Sample Output
    1
    2
    4
     大数处理加dP,,dp的话f[n]=f[n-1]+f[n-2]+f[n-4]
    假设当前要加入第n个学生,如果他是男生,则加入对前面的序列都不会构成影响,
    即为f[n-1],假如他是女生,为保证合法,她前面的那个也就是第n-1个也必须是
    女生,接下来分两种情况讨论,如果第n-2个及以前的都合法,那么显然加入最后
    这两个女生也是合法的额,但是如果不合法呢?很明显,如果不合法,问题应该出在
    尾部,也就是原来f[n-2]不合法,但是加入最后两个女生后也就变得合法了(这句话
    很关键),那么其只能为f[n-4]+男+女,所以即可得到公式
    其实这个讨论的关键在于确定最后两个为女生才能保证合法
    #include<iostream>
    #include<cstdio>
    #include<cstring>
    using namespace std;
    long long dp[1001][1001];
    int main()
    {
       int n;
       memset(dp,0,sizeof(dp));
       dp[1][0]=1;dp[1][1]=1;
       dp[2][0]=1;dp[2][1]=2;
       dp[3][0]=1;dp[3][1]=4;
       dp[4][0]=1;dp[4][1]=7;
       for(int i=5;i<=1000;i++)
         {
           int j,t=dp[i-1][0];
           for(j=1;j<=t;j++)
            {
               dp[i][j]+=dp[i-1][j]+dp[i-2][j]+dp[i-4][j];
               if(dp[i][j]>=10)
               {
                   dp[i][j+1]+=dp[i][j]/10;
                   dp[i][j]%=10;
               }
            }
           while(dp[i][j]>=10)
           {
               dp[i][j+1]+=dp[i][j]/10;
               dp[i][j]%=10;
               j++;
           }
           j=1000;
           while(!dp[i][j])
               j--;
           dp[i][0]=j;
         }
       while(cin>>n)
       {
          for(int i=dp[n][0];i>=1;i--)
             cout<<dp[n][i];
          cout<<endl;
       }
       return 0;
    }


  • 相关阅读:
    phone8 inapp purchasing
    Delegate,Action,Func,匿名方法,匿名委托,事件
    get a full screen popup to work on WP8
    as3.0动态文本大全
    actionScript 3 殿堂之路 第四章 学习收获
    java中的switch case
    Silverlight的DataGrid导出文档
    ArcGIS教程大全
    同步异步请求区别
    XML操作,XPath语法
  • 原文地址:https://www.cnblogs.com/smilesundream/p/6642574.html
Copyright © 2011-2022 走看看