zoukankan      html  css  js  c++  java
  • 591

     

     Box of Bricks 

    Little Bob likes playing with his box of bricks. He puts the bricks one upon another and buildsstacks of different height. ``Look, I've built a wall!'', he tells his older sister Alice. ``Nah, you shouldmake all stacks the same height. Then you would have a real wall.'', she retorts. After a little con-sideration, Bob sees that she is right. So he sets out to rearrange the bricks, one by one, such that allstacks are the same height afterwards. But since Bob is lazy he wants to do this with the minimumnumber of bricks moved. Can you help?

    Input 

    The input consists of several data sets. Each set begins with a line containing the number n of stacksBob has built. The next line contains n numbers, the heights h i of the n stacks. You may assume $1 Ÿle n leŸ 50$and $1 leŸ h_i Ÿle 100$.

    The total number of bricks will be divisible by the number of stacks. Thus, it is always possibleto rearrange the bricks such that all stacks have the same height.

    The input is terminated by a set starting with n = 0. This set should not be processed.

    Output 

    For each set, first print the number of the set, as shown in the sample output. Then print the line`` The minimum number of moves is k.'', where k is the minimum number of bricks thathave to be moved in order to make all the stacks the same height.

    Output a blank line after each set.

    Sample Input 

    6
    5 2 4 1 7 5
    0
    

    Sample Output 

    Set #1
    The minimum number of moves is 5.
    
    #include<stdio.h>
    int main(void)
    {
    	int n,i,count=1;
    	while(scanf("%d",&n)&&n)
    	{
    		int h,k=0,sum=0,a[100]={0};
    		for(i=0;i<n;i++) 
    		{scanf("%d",&a[i]);sum+=a[i];}
    		h=sum/n;
    		for(i=0;i<n;i++)
    			if(a[i]>h)
    				k+=a[i]-h;
    		printf("Set #%d
    The minimum number of moves is %d.
    
    ",count++,k);
    	}
    	return 0;
    }


  • 相关阅读:
    Ubuntu16.04下同时安装Anaconda2与Anaconda3
    ansible 常用模块
    docker 笔记 (7) 限制容器
    linux 磁盘
    docker 笔记 (6)搭建本地registry
    docker 笔记 (5)常用命令
    docker 笔记(4) Dockerfile 常用的指令
    NGINX下配置CACHE-CONTROL
    mysql二进制安装
    [Selenium] Explicit wait 方法
  • 原文地址:https://www.cnblogs.com/snake-hand/p/3148198.html
Copyright © 2011-2022 走看看