zoukankan      html  css  js  c++  java
  • poj2312--Battle City(Bfs)

    Battle City
    Time Limit: 1000MSMemory Limit: 65536K
    Total Submissions: 7712Accepted: 2582

    Description

    Many of us had played the game "Battle city" in our childhood, and some people (like me) even often play it on computer now. 

    What we are discussing is a simple edition of this game. Given a map that consists of empty spaces, rivers, steel walls and brick walls only. Your task is to get a bonus as soon as possible suppose that no enemies will disturb you (See the following picture). 

    Your tank can't move through rivers or walls, but it can destroy brick walls by shooting. A brick wall will be turned into empty spaces when you hit it, however, if your shot hit a steel wall, there will be no damage to the wall. In each of your turns, you can choose to move to a neighboring (4 directions, not 8) empty space, or shoot in one of the four directions without a move. The shot will go ahead in that direction, until it go out of the map or hit a wall. If the shot hits a brick wall, the wall will disappear (i.e., in this turn). Well, given the description of a map, the positions of your tank and the target, how many turns will you take at least to arrive there?

    Input

    The input consists of several test cases. The first line of each test case contains two integers M and N (2 <= M, N <= 300). Each of the following M lines contains N uppercase letters, each of which is one of 'Y' (you), 'T' (target), 'S' (steel wall), 'B' (brick wall), 'R' (river) and 'E' (empty space). Both 'Y' and 'T' appear only once. A test case of M = N = 0 indicates the end of input, and should not be processed.

    Output

    For each test case, please output the turns you take at least in a separate line. If you can't arrive at the target, output "-1" instead.

    Sample Input

    3 4 
    YBEB 
    EERE 
    SSTE 
    0 0 

    Sample Output

    8

    Source

    POJ Monthly,鲁小石

    优先队列, 没啥了。。。。。。。。

    #include <queue>
    #include <cstdio>
    #include <iostream>
    using namespace std;
    char map[300][300]; int ac[4][2] = {010, -1, -1010};
    int n, m;
    struct Maze
    {
        int x, y, step;
        friend bool operator < (Maze x, Maze y)
        {
            return x.step > y.step;        
        } 
    }r, s, t;
    int Bfs(int a, int b)
    {
        r.x = a; r.y = b; r.step = 0;
        map[a][b] = 'S';
        priority_queue<Maze> Q;
        Q.push(r);
        while(!Q.empty())
        {
            s = Q.top(); Q.pop();
            for(int i = 0; i < 4; i++)
            {
                t.x = s.x + ac[i][0];
                t.y = s.y + ac[i][1];
                t.step = s.step + 1;
                if(t.x >= 0 && t.x < n && t.y >= 0 && t.y < m && map[t.x][t.y] != 'R' && map[t.x][t.y] != 'S')
                {
                    if(map[t.x][t.y] == 'T')
                        return t.step;
                    if(map[t.x][t.y] == 'B')
                    {
                        t.step += 1;
                    }
                    map[t.x][t.y] = 'S';
                    Q.push(t);    
                } 
            } 
        }
        return -1

    int main() 
    {
        while(~scanf("%d %d", &n, &m), n+m)
        {
            int x, y;
            for(int i = 0; i < n; i++)
            {
                scanf("%s", map[i]);
                for(int j = 0; j < m; j++)
                {
                    if(map[i][j] == 'Y')
                    {
                        x = i;
                        y = j;
                    }
                }
            }
            printf("%d ", Bfs(x, y));
        }
        return 0;}


  • 相关阅读:
    maven 常用编译
    java 秒时间格式化
    git clone 带用户名密码
    Filebeat占用内存和CPU过高问题排查
    新的一周,全新的开始.
    vs2008 打开aspx文件时设计界面死机情况的解决
    php面试题及答案
    JQuery 对html控件操作总结
    网页常用Javascript
    针对修改php_ini不起作用的方案
  • 原文地址:https://www.cnblogs.com/soTired/p/4779133.html
Copyright © 2011-2022 走看看