Description
"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says.
"The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+...+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
"The second problem is, given an positive integer N, we define an equation like this:
N=a[1]+a[2]+a[3]+...+a[m];
a[i]>0,1<=m<=N;
My question is how many different equations you can find for a given N.
For example, assume N is 4, we can find:
4 = 4;
4 = 3 + 1;
4 = 2 + 2;
4 = 2 + 1 + 1;
4 = 1 + 1 + 1 + 1;
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!"
Input
The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file.
Output
For each test case, you have to output a line contains an integer P which indicate the different equations you have found.
Sample Input
4
10
20
Sample Output
5
42
627
题意:给出一个数n 问 可以拆分为多少种不大于n的整数的和
思路:
代码是zxp那搬来的 完全不明觉厉= =

#include<cstdio> #include<cstring> #include<iostream> #include<algorithm> using namespace std; __int64 a[150]; int main() { int i,j; a[0]=1;//a[1]=1;a[2]=2;a[3]=3;a[4]=5;a[5]=7; for(i=1;i<=120;i++) { for(j=0;i+j<=120;j++) { a[i+j]+=a[j]; } } int n; while(scanf("%d",&n)!=EOF) { printf("%I64d ",a[n]); } return 0; }
dp

#include<cstdio> #include<cstring> #include<iostream> #include<algorithm> using namespace std; int dp[200][200]; int fun(int n,int m) { if(dp[n][m]!=-1) return dp[n][m]; if(n<0||m<0) return 0; if(n==1||m==1) return dp[n][m]=1; else if(m>n) return dp[n][n]=fun(n,n); else if(n==m) return dp[n][m]=fun(n,m-1)+1; else if(n>m) return dp[n][m]=fun(n-m,m)+fun(n,m-1); } int main() { int n; int i,j; memset(dp,-1,sizeof(dp)); while(scanf("%d",&n)!=EOF) { int ans=fun(n,n); printf("%d ",ans); } return 0; }
母函数
#include<cstdio> #include<cstring> #include<iostream> #include<algorithm> using namespace std; int c1[200],c2[200]; void fun(int n) { int i,j,k; memset(c1,0,sizeof(c1)); memset(c2,0,sizeof(c2)); for(i=0;i<=n;i++) { c1[i]=1; } for(i=2;i<=n;i++) { for(j=0;j<=n;j++) { for(k=0;k+j<=n;k+=i) { c2[j+k]+=c1[j]; } } for(j=0;j<=n;j++) { c1[j]=c2[j]; c2[j]=0; } } } int main() { int n; int i,j,k; fun(120); while(scanf("%d",&n)!=EOF) { printf("%d ",c1[n]); } return 0; }