zoukankan      html  css  js  c++  java
  • 洛谷——P2865 [USACO06NOV]路障Roadblocks

    P2865 [USACO06NOV]路障Roadblocks

    题目描述

    Bessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the shortest path. She knows there must be some second-shortest path.

    The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤ N ≤ 5000) intersections, conveniently numbered 1..N. Bessie starts at intersection 1, and her friend (the destination) is at intersection N.

    The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).

    贝茜把家搬到了一个小农场,但她常常回到FJ的农场去拜访她的朋友。贝茜很喜欢路边的风景,不想那么快地结束她的旅途,于是她每次回农场,都会选择第二短的路径,而不象我们所习惯的那样,选择最短路。 贝茜所在的乡村有R(1<=R<=100,000)条双向道路,每条路都联结了所有的N(1<=N<=5000)个农场中的某两个。贝茜居住在农场1,她的朋友们居住在农场N(即贝茜每次旅行的目的地)。 贝茜选择的第二短的路径中,可以包含任何一条在最短路中出现的道路,并且,一条路可以重复走多次。当然咯,第二短路的长度必须严格大于最短路(可能有多条)的长度,但它的长度必须不大于所有除最短路外的路径的长度。

    输入输出格式

    输入格式:

    Line 1: Two space-separated integers: N and R

    Lines 2..R+1: Each line contains three space-separated integers: A, B, and D that describe a road that connects intersections A and B and has length D (1 ≤ D ≤ 5000)

    输出格式:

    Line 1: The length of the second shortest path between node 1 and node N

    输入输出样例

    输入样例#1: 复制
    4 4
    1 2 100
    2 4 200
    2 3 250
    3 4 100
    输出样例#1: 复制
    450

    说明

    Two routes: 1 -> 2 -> 4 (length 100+200=300) and 1 -> 2 -> 3 -> 4 (length 100+250+100=450)

    题目大意:求1~n的次短路

    #include<bits/stdc++.h>
    
    #define N 1000000
    #define inf 0x7fffffff
    using namespace std;
    
    int n,m;
    
    struct edge {
        int to,cost;
        edge(int tv=0,int tc=0):to(tv),cost(tc) {}
    };
    typedef pair<int,int>P;
    vector<edge>G[N];
    int dis[N],dis2[N];
    
    void dijkstra() {
        fill(dis,dis+n,inf);
        fill(dis2,dis2+n,inf);
        priority_queue<P,vector<P>,greater<P> >Q;
        dis[0]=0;
        Q.push(P(0,0));
        while(!Q.empty()) {
            P p=Q.top();
            Q.pop();
            int u=p.second,d=p.first;
            if(dis2[u]<d) continue;
            for(int i=0; i<G[u].size(); i++) {
                edge &e=G[u][i];
                int d2=d+e.cost,v=e.to;
                if(dis[v]>d2) {
                    swap(d2,dis[v]);
                    Q.push(P(dis[v],v));
                }
                if(dis2[v]>d2&&dis[v]<d2){
                    dis2[v]=d2;
                    Q.push(P(dis2[v],v));
                }
            }
        }
    }
    
    int main() {
        scanf("%d%d",&n,&m);
        for(int a,b,c,i=1; i<=m; i++) {
            scanf("%d%d%d",&a,&b,&c);
            G[a-1].push_back(edge(b-1,c));
            G[b-1].push_back(edge(a-1,c));
        }
        dijkstra();
        printf("%d",dis2[n-1]);
        return 0;
    }
    #include<bits/stdc++.h>
    
    #define N 1000000
    #define inf 0x7fffffff
    using namespace std;
    
    int n,m,tot,head[N],dis[N],dis2[N];
    struct pos {
        int to,next,w;
    } e[N];
    void add(int u,int v,int w) {
        e[++tot].to=v;
        e[tot].next=head[u];
        head[u]=tot;
        e[tot].w=w;
    }
    struct node {
        int u,d;
        bool operator <(node x)const {
            return d>x.d;
        }
    };
    priority_queue<node>Q;
    void spfa() {
        fill(dis,dis+n+1,inf);
        fill(dis2,dis2+n+1,inf);
        Q.push(node{1,0});
        while(!Q.empty()) {
            node p=Q.top();
            Q.pop();
            int u=p.u,d=p.d;
            if(dis2[u]<d) continue;
            for(int i=head[u]; i; i=e[i].next) {
                int v=e[i].to,d2=d+e[i].w;
                if(dis[v]>d2) {
                    swap(dis[v],d2);
                    Q.push(node{v,dis[v]});
                }if(dis2[v]>d2&&dis[v]<d2){
                    dis2[v]=d2;
                    Q.push(node{v,dis2[v]});
                }
            }
        }
    }
    
    int main() {
        scanf("%d%d",&n,&m);
        for(int a,b,c,i=1; i<=m; i++) {
            scanf("%d%d%d",&a,&b,&c);
            add(a,b,c),add(b,a,c);
        }
        spfa();
        printf("%d",dis2[n]);
        return 0;
    }
  • 相关阅读:
    经典面试题sql基础篇-50常用的sql语句(有部分错误)
    Java中类方法与实例方法的区别
    认识区块链,认知区块链— —数据上链
    Excel中RATE函数的Java实现
    Excel中PMT函数的Java实现
    xtrabackup 全量备份、恢复数据
    程序员成长过程中不可忽略的几本书
    基于SpringBoot的WEB API项目的安全设计
    基于SpringCloud的Microservices架构实战案例-在线API管理
    他山之石,可以攻玉:从别人的项目中汲取经验
  • 原文地址:https://www.cnblogs.com/song-/p/9600530.html
Copyright © 2011-2022 走看看