zoukankan      html  css  js  c++  java
  • hdu 1004

    Let the Balloon Rise

    Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
    Total Submission(s): 57595    Accepted Submission(s): 21046


    Problem Description
    Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

    This year, they decide to leave this lovely job to you.
     
    Input
    Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

    A test case with N = 0 terminates the input and this test case is not to be processed.
     
    Output
    For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
     
    Sample Input
    5
    green
    red
    blue
    red
    red
    3
    pink
    orange
    pink
    0
     
    Sample Output
    red
    pink
     
    代码:
    #include "stdio.h"
    #include "string.h"
    char a[1005][16];
    int main()
    {  int i,j,n;
       int a1=0,a2=0,k=0;
        while(scanf("%d", &n)!=EOF && n!=0)
       { for(i=0;i<n;i++)
          {
           scanf("%s",a[i]);
       
          }
        for(i=0;i<n;i++)
        {  a1=0;
           for(j=0;j<n;j++)
           {if(strcmp(a[i],a[j])==0)
               {a1++;
               }
           }
           if(a1>a2)
           {a2=a1;
           k=i;
            }
        }
        printf("%s ",a[k]);
        k=0;
       }
        return 0;
    }
     
     
    注意:printf后一定要让k=0,否则当下一个k值小于上一个k值是会导致a[k]的内容不能更新
     
  • 相关阅读:
    多进程访问同一文件问题
    在主页面中实现Iframe中的子页面的切换
    在任务栏显示地理坐标
    ajax异步调用过程
    实现DIV标签的显示与隐藏
    使用supermap的心得
    nokia手机问题
    sys.webforms.pagerequestmanagerservererrorexception回发或回调参数无效
    AjaxScript地图打印[转]
    js获取下拉框中的值
  • 原文地址:https://www.cnblogs.com/songmingtao/p/3219494.html
Copyright © 2011-2022 走看看