zoukankan      html  css  js  c++  java
  • [ACM] hdu Wall (凸包周长)

    Problem Description

    Once upon a time there was a greedy King who ordered his chief Architect to build a wall around the King's castle. The King was so greedy, that he would not listen to his Architect's proposals to build a beautiful brick wall with a perfect shape and nice tall towers. Instead, he ordered to build the wall around the whole castle using the least amount of stone and labor, but demanded that the wall should not come closer to the castle than a certain distance. If the King finds that the Architect has used more resources to build the wall than it was absolutely necessary to satisfy those requirements, then the Architect will loose his head. Moreover, he demanded Architect to introduce at once a plan of the wall listing the exact amount of resources that are needed to build the wall.
    Your task is to help poor Architect to save his head, by writing a program that will find the minimum possible length of the wall that he could build around the castle to satisfy King's requirements.



    The task is somewhat simplified by the fact, that the King's castle has a polygonal shape and is situated on a flat ground. The Architect has already established a Cartesian coordinate system and has precisely measured the coordinates of all castle's vertices in feet.

    Input

    The first line of the input file contains two integer numbers N and L separated by a space. N (3 <= N <= 1000) is the number of vertices in the King's castle, and L (1 <= L <= 1000) is the minimal number of feet that King allows for the wall to come close to the castle.

    Next N lines describe coordinates of castle's vertices in a clockwise order. Each line contains two integer numbers Xi and Yi separated by a space (-10000 <= Xi, Yi <= 10000) that represent the coordinates of ith vertex. All vertices are different and the sides of the castle do not intersect anywhere except for vertices.

    Output

    Write to the output file the single number that represents the minimal possible length of the wall in feet that could be built around the castle to satisfy King's requirements. You must present the integer number of feet to the King, because the floating numbers are not invented yet. However, you must round the result in such a way, that it is accurate to 8 inches (1 foot is equal to 12 inches), since the King will not tolerate larger error in the estimates.

    This problem contains multiple test cases!

    The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

    The output format consists of N output blocks. There is a blank line between output blocks.

    Sample Input

    1
    
    9 100
    200 400
    300 400
    300 300
    400 300
    400 400
    500 400
    500 200
    350 200
    200 200
    

    Sample Output

    1628
    

    Source

    Northeastern Europe 2001

    解题思路:

    graham扫描算法求凸包周长。

    模板:

    struct Point
    {
        double x,y;
    };
    
    Point point[1003];
    Point stack[1003];//把构成凸包的点存到stack中,存入点的个数为top个
    int c,n,top;
    double l,r;
    
    int multi(Point p0,Point p1,Point p2)
    {
        return ((p1.x-p0.x)*(p2.y-p0.y)-(p2.x-p0.x)*(p1.y-p0.y));
    }
    
    double dis(Point p1,Point p2)
    {
        return sqrt((p1.x-p2.x)*(p1.x-p2.x)+(p1.y-p2.y)*(p1.y-p2.y));
    }
    
    int cmp(Point a,Point b)
    {
        if(multi(point[0],a,b)>0) return 1;
            if(multi(point[0],a,b)<0) return 0;
                if(dis(point[0],a)<dis(point[0],b))
                    return 1;
                    return 0;
    }
    void graham()
    {
        int i,k=0;
        Point temp;
        for(i=1; i<n; i++)
            if((point[i].y<point[k].y)||((point[i].y==point[k].y)&&(point[i].x<point[k].x)))
                k=i;
        temp=point[0];
        point[0]=point[k];
        point[k]=temp;
        sort(point+1,point+n,cmp);//按极角的大小进行排序
        stack[0]=point[0];
        stack[1]=point[1];
       top=1;
       i=2;
         while(i<n)
        {
            if(multi(stack[top],stack[top-1],point[i])<=0)//AB x AC>0 AC在AB的逆时针方向
                                                           //AB x AC<0 AC在AB的顺时针方向
                                                           //AB x AC=0 ABC 共线
                stack[++top]=point[i++];
            else
                top--;
        }
    }


     

    本题代码:

    #include <iostream>
    #include <iomanip>
    #include <algorithm>
    #include <cmath>
    using namespace std;
    
    struct Point
    {
        double x,y;
    };
    
    Point point[1003];
    Point stack[1003];//把构成凸包的点存到stack中,存入点的个数为top个
    int c,n,top;
    double l,r;
    
    int multi(Point p0,Point p1,Point p2)
    {
        return ((p1.x-p0.x)*(p2.y-p0.y)-(p2.x-p0.x)*(p1.y-p0.y));
    }
    
    double dis(Point p1,Point p2)
    {
        return sqrt((p1.x-p2.x)*(p1.x-p2.x)+(p1.y-p2.y)*(p1.y-p2.y));
    }
    
    int cmp(Point a,Point b)
    {
        if(multi(point[0],a,b)>0) return 1;
            if(multi(point[0],a,b)<0) return 0;
                if(dis(point[0],a)<dis(point[0],b))
                    return 1;
                    return 0;
    }
    void graham()
    {
        int i,k=0;
        Point temp;
        for(i=1; i<n; i++)
            if((point[i].y<point[k].y)||((point[i].y==point[k].y)&&(point[i].x<point[k].x)))
                k=i;
        temp=point[0];
        point[0]=point[k];
        point[k]=temp;
        sort(point+1,point+n,cmp);//按极角的大小进行排序
        stack[0]=point[0];
        stack[1]=point[1];
       top=1;
       i=2;
         while(i<n)
        {
            if(multi(stack[top],stack[top-1],point[i])<=0)//AB x AC>0 AC在AB的逆时针方向
                                                           //AB x AC<0 AC在AB的顺时针方向
                                                           //AB x AC=0 ABC 共线
                stack[++top]=point[i++];
            else
                top--;
        }
    }
    int main()
    {
        cin>>c;
        for(int m=1;m<=c;m++)
        {
            cin>>n>>r;
            for(int j=0;j<n;j++)
                cin>>point[j].x>>point[j].y;
            graham();
            l=0;
            for(int j=0;j<top;j++)
                l+=dis(stack[j],stack[j+1]);
            l+=dis(stack[top],stack[0]);
            l+=3.1415927*2*r;//加上四小段弧组成的圆的周长
            cout<<setiosflags(ios::fixed)<<setprecision(0)<<l<<endl;
            if(m!=c)
                cout<<endl;
        }
        return 0;
    }
    


     

  • 相关阅读:
    利用FlashPaper实现类似百度文库功能
    浅谈Oracle函数返回Table集合
    Oracle 触发器在日志管理开发中的应用
    Putty 工具 保存配置的 小技巧
    java.util.Date转java.sql.Date丢失时间问题
    java String和Date转换
    springboot项目使用拦截器修改/添加前端传输到后台header和cookie参数
    Spring的使用及Spring3.2控制器增强@ControllerAdvice
    使用fastjson统一序列化响应格式
    【转】Elastic-Job
  • 原文地址:https://www.cnblogs.com/sr1993/p/3697787.html
Copyright © 2011-2022 走看看